summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJure Varlec (exzombie) <jure.varlec@gmail.com>2010-08-29 10:20:09 +0000
committerJure Varlec (exzombie) <jure.varlec@gmail.com>2010-08-29 10:20:09 +0000
commit3952563a1613ea934979d4afaffaa21238aa20da (patch)
treeee3b4cfc324d9bbe1f6e6d63f5b62cad234ed3b6 /app-text
parentgames-fps/gzdoom: gzdoom version bump, add fluidsynth support (w/ useflag) (diff)
downloadsunrise-3952563a1613ea934979d4afaffaa21238aa20da.tar.gz
sunrise-3952563a1613ea934979d4afaffaa21238aa20da.tar.bz2
sunrise-3952563a1613ea934979d4afaffaa21238aa20da.zip
app-text/u2ps: New ebuild for bug #335117. Thanks to hwoarang and Nikoli.
svn path=/sunrise/; revision=11256
Diffstat (limited to 'app-text')
-rw-r--r--app-text/u2ps/ChangeLog8
-rw-r--r--app-text/u2ps/metadata.xml9
-rw-r--r--app-text/u2ps/u2ps-0.8.1.ebuild45
3 files changed, 62 insertions, 0 deletions
diff --git a/app-text/u2ps/ChangeLog b/app-text/u2ps/ChangeLog
new file mode 100644
index 000000000..d17319a37
--- /dev/null
+++ b/app-text/u2ps/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-text/u2ps
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 29 Aug 2010; Jure Varlec (exzombie) <jure.varlec@gmail.com>
+ +u2ps-0.8.1.ebuild, +metadata.xml:
+ New ebuild for bug #335117. Thanks to hwoarang and Nikoli.
+
diff --git a/app-text/u2ps/metadata.xml b/app-text/u2ps/metadata.xml
new file mode 100644
index 000000000..cdfc6a83f
--- /dev/null
+++ b/app-text/u2ps/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+ <use>
+ <flag name='fonts'>Install a more complete set of unicode fonts</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-text/u2ps/u2ps-0.8.1.ebuild b/app-text/u2ps/u2ps-0.8.1.ebuild
new file mode 100644
index 000000000..5eb0613cc
--- /dev/null
+++ b/app-text/u2ps/u2ps-0.8.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="A text to PostScript converter like a2ps, but supports UTF-8"
+HOMEPAGE="http://u2ps.berlios.de/"
+SRC_URI="!fonts? ( mirror://berlios/${PN}/${P}.tar.gz )
+ fonts? ( mirror://berlios/${PN}/${PN}-full-${PV}.tar.gz )"
+
+LICENSE="GPL-3 GPL-3-with-font-exception free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fonts"
+
+DEPEND="
+ >=dev-lang/perl-5.6
+ dev-perl/Text-CharWidth
+ app-text/ghostscript-gpl
+"
+RDEPEND="${DEPEND}"
+
+use fonts && S="${WORKDIR}/${PN}-full-${PV}"
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --with-perl=/usr/bin/perl \
+ --with-gs=/usr/bin/gs \
+ || die 'configure failed'
+}
+
+src_compile() {
+ emake || die 'make failed'
+ emake man || die 'make man failed'
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die 'install failed'
+ dodoc README DESIGN || die 'dodoc failed'
+ doman man/u2ps.1 || die 'doman failed'
+}