summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2012-04-09 22:41:50 +0300
committerJauhien Piatlicki (jauhien) <piatlicki@gmail.com>2012-04-09 22:41:50 +0300
commit61f4d7b5ecc89c7fb757195f6396ddbac6eb77d0 (patch)
tree9c0a236e579416457f56bf2f704cbc8f2eec71b0 /app-text
parentLicense for app-text/discount. (diff)
downloadsunrise-61f4d7b5ecc89c7fb757195f6396ddbac6eb77d0.tar.gz
sunrise-61f4d7b5ecc89c7fb757195f6396ddbac6eb77d0.tar.bz2
sunrise-61f4d7b5ecc89c7fb757195f6396ddbac6eb77d0.zip
app-text/discount: New ebuild for bug #294000 thanks to hasufell from #gentoo-sunrise and Egil Hanger.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/discount/ChangeLog11
-rw-r--r--app-text/discount/Manifest4
-rw-r--r--app-text/discount/discount-2.1.3.ebuild36
-rw-r--r--app-text/discount/metadata.xml7
4 files changed, 58 insertions, 0 deletions
diff --git a/app-text/discount/ChangeLog b/app-text/discount/ChangeLog
new file mode 100644
index 000000000..2212501dc
--- /dev/null
+++ b/app-text/discount/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/discount
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*discount-2.1.3 (09 Apr 2012)
+
+ 09 Apr 2012; Jauhien Piatlicki (jauhien) piatlicki@gmail.com
+ +discount-2.1.3.ebuild, +metadata.xml:
+ New ebuild for bug #294000 thanks to hasufell from #gentoo-sunrise and Egil
+ Hanger.
+
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
new file mode 100644
index 000000000..2db73f17d
--- /dev/null
+++ b/app-text/discount/Manifest
@@ -0,0 +1,4 @@
+DIST discount-2.1.3.tar.bz2 82844 RMD160 17be5f9323fbed9ffe76ca4ef059258c3e782c66 SHA1 9757f14f693ba77417a7318f9d6f2a9a687d9e5d SHA256 7280da7a27be42244311912eeee19695623f196817ec08f43b652fcc2ded975d
+EBUILD discount-2.1.3.ebuild 892 RMD160 eef0f2a35db8218dcc7f3dd42a041a0f8d672cce SHA1 e2dc6d9a7326835e960df613d56e05cb00407deb SHA256 b3eac3e1b54c5985a785da02b4eaeda0595346ff655f2f4f4c142d50e4be8842
+MISC ChangeLog 342 RMD160 d878465e81d41d6e49b6df85840f7a67033f1895 SHA1 b523c73a988d725af102a7c9c586c93259aedd8a SHA256 4d5ac336c05e4ced518c1a1f5f55225681a8e381968d1abac795eaad770aea37
+MISC metadata.xml 214 RMD160 efd8175069efb91061298ff4584218b633e44678 SHA1 d372fdbfcb7fd07a4082961d3f3527be4fca1d60 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154
diff --git a/app-text/discount/discount-2.1.3.ebuild b/app-text/discount/discount-2.1.3.ebuild
new file mode 100644
index 000000000..b57126229
--- /dev/null
+++ b/app-text/discount/discount-2.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="An implementation of John Gruber's Markdown text to html language written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="DLPARSONS"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="minimal"
+
+src_prepare() {
+ # for QA, we remove the Makefiles usage of install -s
+ sed -e '/INSTALL_PROGRAM/s#-s ##' -i configure.inc \
+ || die "sed can't fix stripping of files"
+}
+
+src_configure() {
+ local myconf
+ use minimal || myconf="--enable-all-features"
+
+ ./configure.sh "${myconf}" \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+}
+
+src_install() {
+ local myinstall
+ use minimal && myinstall="install" || myinstall="install.everything"
+ emake DESTDIR="${D}" ${myinstall}
+}
diff --git a/app-text/discount/metadata.xml b/app-text/discount/metadata.xml
new file mode 100644
index 000000000..cc3fe2494
--- /dev/null
+++ b/app-text/discount/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>