summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-04-10 20:47:31 +0000
committerAli Polatel <hawking@gentoo.org>2007-04-10 20:47:31 +0000
commit400281a8e9b6a625aa0b59b6849a8dea4657ee2d (patch)
tree6ffbdfc25c05d27fb544e608bb24c76c70c724ff /app-vim/clewn/clewn-1.10.ebuild
parentgames-board/openyahtzee: Added ~x86-fbsd keyword (diff)
downloadsunrise-400281a8e9b6a625aa0b59b6849a8dea4657ee2d.tar.gz
sunrise-400281a8e9b6a625aa0b59b6849a8dea4657ee2d.tar.bz2
sunrise-400281a8e9b6a625aa0b59b6849a8dea4657ee2d.zip
app-vim/clewn: Version bump
svn path=/sunrise/; revision=3403
Diffstat (limited to 'app-vim/clewn/clewn-1.10.ebuild')
-rw-r--r--app-vim/clewn/clewn-1.10.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-vim/clewn/clewn-1.10.ebuild b/app-vim/clewn/clewn-1.10.ebuild
new file mode 100644
index 000000000..040c79fba
--- /dev/null
+++ b/app-vim/clewn/clewn-1.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils vim-doc
+
+DESCRIPTION="A small utility which allows debugging from within vim"
+HOMEPAGE="http://clewn.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+DEPEND=">=app-editors/gvim-7.0
+ sys-libs/readline"
+RDEPEND="${DEPEND}
+ sys-devel/gdb"
+
+pkg_setup() {
+ if ! built_with_use app-editors/gvim netbeans ; then
+ eerror "Please (re)emerge gvim with netbeans USE flag on before "
+ eerror "emerging clewn"
+ die "please (re)emerge app-editors/gvim with USE='netbeans'"
+ fi
+}
+
+src_compile() {
+ vimdir=/usr/share/vim/vimfiles econf $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ update_vim_helptags
+}