summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Zaleski (rob_zales) <rzaleski81@yahoo.com>2006-10-07 13:40:03 +0000
committerRobert Zaleski (rob_zales) <rzaleski81@yahoo.com>2006-10-07 13:40:03 +0000
commitaf68eb15832540fe15d767053677356c9ec5d69f (patch)
treeaf7cdc1849817b41f9ddb8caf91835dfd544c8a1 /app-vim/clewn/clewn-1.9.ebuild
parentdev-ruby/rspec: Version bump. (diff)
downloadsunrise-af68eb15832540fe15d767053677356c9ec5d69f.tar.gz
sunrise-af68eb15832540fe15d767053677356c9ec5d69f.tar.bz2
sunrise-af68eb15832540fe15d767053677356c9ec5d69f.zip
app-vim/clewn: Version bump from 1.8.1 to 1.9 for Clewn
svn path=/sunrise/; revision=1425
Diffstat (limited to 'app-vim/clewn/clewn-1.9.ebuild')
-rw-r--r--app-vim/clewn/clewn-1.9.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-vim/clewn/clewn-1.9.ebuild b/app-vim/clewn/clewn-1.9.ebuild
new file mode 100644
index 000000000..846baf318
--- /dev/null
+++ b/app-vim/clewn/clewn-1.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils vim-doc
+
+DESCRIPTION="A small utility which allows debugging from within vim"
+HOMEPAGE="http://clewn.sourceforge.net"
+SRC_URI="mirror://sourceforge/clewn/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=app-editors/gvim-7.0
+ sys-libs/readline"
+RDEPEND=${RDEPEND}
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use app-editors/gvim netbeans ; then
+ eerror "Please (re)emerge gvim with netbeans USE flag on before "
+ eerror "emerging clewn"
+ die "please (re)emerge app-editors/gvim with USE='netbeans'"
+ fi
+}
+
+src_install() {
+ dodoc README.txt CHANGELOG
+ dobin clewn
+ dodir /usr/share/vim/vimfiles
+ tar -xzf ${S}/runtime/clewn_runtime.tgz -C ${D}/usr/share/vim/vimfiles
+}
+
+pkg_postinst() {
+ update_vim_helptags
+}