summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Fortino (nfortino) <nfortino@gmail.com>2009-03-16 21:01:11 +0000
committerNick Fortino (nfortino) <nfortino@gmail.com>2009-03-16 21:01:11 +0000
commit74cc21db8b9815c68b6ed37906661f7ef6c7e026 (patch)
tree6c9d8634303bf361fa0cce78d1c6f0ffb28a9c2c /app-vim/clewn/clewn-9999.ebuild
parentapp-misc/rainlendar-lite: Update ebuild to use EAPI 2. Thanks to Cristian Rup... (diff)
downloadsunrise-74cc21db8b9815c68b6ed37906661f7ef6c7e026.tar.gz
sunrise-74cc21db8b9815c68b6ed37906661f7ef6c7e026.tar.bz2
sunrise-74cc21db8b9815c68b6ed37906661f7ef6c7e026.zip
app-vim/clewn: Update ebuild to use EAPI 2. Thanks to Cristian Ruppert and Thomas Sachau for review
svn path=/sunrise/; revision=8104
Diffstat (limited to 'app-vim/clewn/clewn-9999.ebuild')
-rw-r--r--app-vim/clewn/clewn-9999.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/app-vim/clewn/clewn-9999.ebuild b/app-vim/clewn/clewn-9999.ebuild
index 8de0ec6b5..5a1166f84 100644
--- a/app-vim/clewn/clewn-9999.ebuild
+++ b/app-vim/clewn/clewn-9999.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
inherit eutils subversion vim-doc
DESCRIPTION="A small utility which allows debugging from within vim"
@@ -13,22 +15,13 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="debug"
-DEPEND=">=app-editors/gvim-7.0
+DEPEND=">=app-editors/gvim-7.0[netbeans]
sys-libs/readline"
RDEPEND="${DEPEND}
sys-devel/gdb"
-pkg_setup() {
- if ! built_with_use app-editors/gvim netbeans ; then
- eerror "Please (re)emerge gvim with netbeans USE flag on before "
- eerror "emerging clewn"
- die "please (re)emerge app-editors/gvim with USE='netbeans'"
- fi
-}
-
-src_compile() {
+src_configure() {
vimdir=/usr/share/vim/vimfiles econf $(use_enable debug)
- emake || die "emake failed"
}
src_install() {