summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-04-15 17:12:32 +0000
committerAli Polatel <hawking@gentoo.org>2007-04-15 17:12:32 +0000
commit8a433015cb336ec22b235d129ca30902997f3561 (patch)
tree7d6e40ad0891ec2c3f90ea0376fbbcffa58e20f5 /app-vim/clewn/clewn-9999.ebuild
parentremove empty filesdirs (diff)
downloadsunrise-8a433015cb336ec22b235d129ca30902997f3561.tar.gz
sunrise-8a433015cb336ec22b235d129ca30902997f3561.tar.bz2
sunrise-8a433015cb336ec22b235d129ca30902997f3561.zip
app-vim/clewn: Added svn version
svn path=/sunrise/; revision=3451
Diffstat (limited to 'app-vim/clewn/clewn-9999.ebuild')
-rw-r--r--app-vim/clewn/clewn-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-vim/clewn/clewn-9999.ebuild b/app-vim/clewn/clewn-9999.ebuild
new file mode 100644
index 000000000..b182029eb
--- /dev/null
+++ b/app-vim/clewn/clewn-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils subversion vim-doc
+
+DESCRIPTION="A small utility which allows debugging from within vim"
+HOMEPAGE="http://clewn.sourceforge.net/"
+ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/${PN}/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+DEPEND=">=app-editors/gvim-7.0
+ sys-libs/readline"
+RDEPEND="${DEPEND}
+ sys-devel/gdb"
+
+pkg_setup() {
+ if ! built_with_use app-editors/gvim netbeans ; then
+ eerror "Please (re)emerge gvim with netbeans USE flag on before "
+ eerror "emerging clewn"
+ die "please (re)emerge app-editors/gvim with USE='netbeans'"
+ fi
+}
+
+src_compile() {
+ vimdir=/usr/share/vim/vimfiles econf $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ update_vim_helptags
+}