summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo D'Autilia (sYdRo) <sydro@salug.it>2010-03-05 17:08:44 +0000
committerAngelo D'Autilia (sYdRo) <sydro@salug.it>2010-03-05 17:08:44 +0000
commit952d061554d83e9b93d97563dfd6a9c0bbef831b (patch)
treef15d540204c096f7384c59145927b2ce8df0bcaa /dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild
parentdev-games/game-editor: New ebuild for bug 289276 (diff)
downloadsunrise-952d061554d83e9b93d97563dfd6a9c0bbef831b.tar.gz
sunrise-952d061554d83e9b93d97563dfd6a9c0bbef831b.tar.bz2
sunrise-952d061554d83e9b93d97563dfd6a9c0bbef831b.zip
dev-cpp/gtkmm-utils: Version bump to gtkmm-utils-0.4.1
svn path=/sunrise/; revision=10238
Diffstat (limited to 'dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild')
-rw-r--r--dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild b/dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild
new file mode 100644
index 000000000..c78624a05
--- /dev/null
+++ b/dev-cpp/gtkmm-utils/gtkmm-utils-0.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator
+
+MY_PVM=$(get_version_component_range 1-2)
+
+DESCRIPTION="Utility functions, classes and widgets written on top of gtkmm and glibmm."
+HOMEPAGE="http://code.google.com/p/gtkmm-utils/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-cpp/gtkmm-2.10.0"
+DEPEND="doc? ( app-doc/doxygen )
+ dev-util/pkgconfig
+ ${RDEPEND}"
+
+src_compile() {
+ econf $(use_enable doc documentation)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}