summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin von Gagern (MvG) <Martin.vGagern@gmx.net>2008-12-30 20:28:00 +0000
committerMartin von Gagern (MvG) <Martin.vGagern@gmx.net>2008-12-30 20:28:00 +0000
commitb132a33ca933a15363858edf619d66e4cc313509 (patch)
tree12c62081a44bbdb0291ebe85338236d131ad6759 /dev-db/dbf/dbf-0.9.0.ebuild
parentdev-libs/libdbf: First of two ebuilds from bug 85553 (diff)
downloadsunrise-b132a33ca933a15363858edf619d66e4cc313509.tar.gz
sunrise-b132a33ca933a15363858edf619d66e4cc313509.tar.bz2
sunrise-b132a33ca933a15363858edf619d66e4cc313509.zip
dev-db/dbf: Second of two ebuilds from bug 85553
svn path=/sunrise/; revision=7557
Diffstat (limited to 'dev-db/dbf/dbf-0.9.0.ebuild')
-rw-r--r--dev-db/dbf/dbf-0.9.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-db/dbf/dbf-0.9.0.ebuild b/dev-db/dbf/dbf-0.9.0.ebuild
new file mode 100644
index 000000000..e9062c22e
--- /dev/null
+++ b/dev-db/dbf/dbf-0.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MY_PN="${PN}-core"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Command line tool to convert dBASE (III, IV, 5.0) files to CSV or SQL"
+HOMEPAGE="http://developer.berlios.de/projects/dbf/"
+SRC_URI="mirror://berlios/dbf/${MY_P}.src.zip"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/libdbf"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-perl/XML-Parser
+ doc? ( app-text/docbook-sgml-utils )
+ dev-util/pkgconfig"
+
+
+S=${WORKDIR}/${MY_PN}
+
+src_compile() {
+ sed -i 's/docbook-to-man/$(DOC_TO_MAN)/' man/Makefile*
+ chmod u+x configure
+ if use doc; then
+ export DOC_TO_MAN=docbook2man
+ fi
+ econf
+ emake || die "emake failed"
+ if use doc; then
+ mv man/DBF.SECTION man/dbf.1 || die "Error moving man page"
+ fi
+}
+
+src_install() {
+ chmod u+x install-sh
+ emake DESTDIR="${D}" install || die "make install failed"
+}