summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-12-07 18:27:21 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-12-07 18:27:21 +0000
commit1d9ca9de4dd662962c53dc52cfe1abfe94d972dd (patch)
tree1e601525d67d2f799601c624d64c208f273c4c79 /dev-db/soci/soci-2.2.0.ebuild
parentmedia-sound/exaile: New useflag for cd audio playback support (diff)
downloadsunrise-1d9ca9de4dd662962c53dc52cfe1abfe94d972dd.tar.gz
sunrise-1d9ca9de4dd662962c53dc52cfe1abfe94d972dd.tar.bz2
sunrise-1d9ca9de4dd662962c53dc52cfe1abfe94d972dd.zip
soci/files/digest-soci-2.1.0: Version bump. Adjusted to new build system.
svn path=/sunrise/; revision=2148
Diffstat (limited to 'dev-db/soci/soci-2.2.0.ebuild')
-rw-r--r--dev-db/soci/soci-2.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-db/soci/soci-2.2.0.ebuild b/dev-db/soci/soci-2.2.0.ebuild
new file mode 100644
index 000000000..4f2a075bf
--- /dev/null
+++ b/dev-db/soci/soci-2.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A database access library for C++ that makes the illusion of embedding SQL queries in the regular C++ code."
+HOMEPAGE="http://soci.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="debug firebird mysql postgres sqlite3 static"
+
+RDEPEND="firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/libpq )
+ sqlite3? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_compile() {
+ local myconf
+ use debug && myconf="--enable-debug=yes" || myconf="--enable-debug=no"
+ econf ${myconf} \
+ $(use_enable mysql backend-mysql) \
+ $(use_enable sqlite3 backend-sqlite3) \
+ $(use_enable postgres backend-postgresql) \
+ $(use_enable firebird backend-firebird) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGES README
+ dohtml -r doc/*
+}