summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-08-06 10:47:45 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-08-06 10:47:45 +0000
commit36ff80393658acbfba3a636af0c1357da2329891 (patch)
treea751ce90c24dd9cba7782ddb53e19b9bbbfb1426 /dev-db/sqlitewrapped/sqlitewrapped-1.3.ebuild
parentRemoving net-im/zephyr, as it is unmaintained upstream, and I don't use it an... (diff)
downloadsunrise-36ff80393658acbfba3a636af0c1357da2329891.tar.gz
sunrise-36ff80393658acbfba3a636af0c1357da2329891.tar.bz2
sunrise-36ff80393658acbfba3a636af0c1357da2329891.zip
dev-db/sqlitewrapped: New ebuild for bug #142961
svn path=/sunrise/; revision=796
Diffstat (limited to 'dev-db/sqlitewrapped/sqlitewrapped-1.3.ebuild')
-rw-r--r--dev-db/sqlitewrapped/sqlitewrapped-1.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-db/sqlitewrapped/sqlitewrapped-1.3.ebuild b/dev-db/sqlitewrapped/sqlitewrapped-1.3.ebuild
new file mode 100644
index 000000000..8bd839455
--- /dev/null
+++ b/dev-db/sqlitewrapped/sqlitewrapped-1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+KEYWORDS="~x86"
+
+DESCRIPTION="Another C++ wrapper for the SQLite C API"
+HOMEPAGE="http://www.alhem.net/project/sqlite/index.html"
+SRC_URI="http://www.alhem.net/project/sqlite/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-db/sqlite-3"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/\(CPPFLAGS\) =/\1+=/' \
+ -e 's/-Wall -g -O2/-fPIC/' \
+ -e 's#/usr/devel#/usr#' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ dolib libsqlitewrapped.a
+ insinto /usr/include
+ doins libsqlitewrapped.h
+}