summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Schultz (mschultz) <mattsch@gmail.com>2009-11-24 16:19:21 +0000
committerMatthew Schultz (mschultz) <mattsch@gmail.com>2009-11-24 16:19:21 +0000
commitb10761c8e2d9fb2787b7ee36c9a0049bd8c3daeb (patch)
tree93eb4d378aacfec525e92a6f858616d51ec3d64b /dev-java
parentnet-misc/videojak: New ebuild for bug 294333. Thanks to scarabeus. (diff)
downloadsunrise-b10761c8e2d9fb2787b7ee36c9a0049bd8c3daeb.tar.gz
sunrise-b10761c8e2d9fb2787b7ee36c9a0049bd8c3daeb.tar.bz2
sunrise-b10761c8e2d9fb2787b7ee36c9a0049bd8c3daeb.zip
dev-java/selenium-remote-control: New ebuild for bug 294308.
svn path=/sunrise/; revision=9598
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/selenium-remote-control/ChangeLog8
-rw-r--r--dev-java/selenium-remote-control/Manifest4
-rw-r--r--dev-java/selenium-remote-control/metadata.xml6
-rw-r--r--dev-java/selenium-remote-control/selenium-remote-control-1.0.1.ebuild36
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/selenium-remote-control/ChangeLog b/dev-java/selenium-remote-control/ChangeLog
new file mode 100644
index 000000000..b56e41ec2
--- /dev/null
+++ b/dev-java/selenium-remote-control/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-java/selenium-remote-control
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 24 Nov 2009; Matthew Schultz (mschultz) <mattsch@gmail.com>
+ +selenium-remote-control-1.0.1.ebuild, +metadata.xml:
+ New ebuild for bug 294308.
+
diff --git a/dev-java/selenium-remote-control/Manifest b/dev-java/selenium-remote-control/Manifest
new file mode 100644
index 000000000..cb401c697
--- /dev/null
+++ b/dev-java/selenium-remote-control/Manifest
@@ -0,0 +1,4 @@
+DIST selenium-remote-control-1.0.1-dist.zip 10971251 RMD160 45489db4da85a248c06d8cb963777b1e51319ece SHA1 b79605f790d801cc553666bf7d61b94c6d535d9f SHA256 e8c4e50c99c774cbc25d96452af272232dab23273e086c96ed83ceec6bdf79a0
+EBUILD selenium-remote-control-1.0.1.ebuild 1085 RMD160 54af5a58fe791db01140a8e8218b2aca408e6ade SHA1 1d79c5b143e205b5cd328081e71505c498f3587b SHA256 259bc854ed016001ef5aeae3e07481f03485e4ff82b5cb6e88407752cfa05e6a
+MISC ChangeLog 281 RMD160 c9dc740f9670a0c20cd1c5f0c0ff397059e26060 SHA1 d89d96be045c2e644920ec76ea564bda5bbde4b0 SHA256 6bff7e073b70addb40b5924e27976362c1d7c841d14fad9b7d23618a33f4696b
+MISC metadata.xml 320 RMD160 b85b169bd957a751e3e32b5f661ecc35261d3a32 SHA1 003627782e9ee4322d83641835a6284d98d01e5c SHA256 ad31a50e8761c9175377fdcc54abcf0a720ac3bce58355133da6009454eeadc9
diff --git a/dev-java/selenium-remote-control/metadata.xml b/dev-java/selenium-remote-control/metadata.xml
new file mode 100644
index 000000000..fd76cd45c
--- /dev/null
+++ b/dev-java/selenium-remote-control/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <longdescription>A server which automatically launches and kills browsers, and acts as a HTTP proxy for web requests from them.</longdescription>
+</pkgmetadata>
diff --git a/dev-java/selenium-remote-control/selenium-remote-control-1.0.1.ebuild b/dev-java/selenium-remote-control/selenium-remote-control-1.0.1.ebuild
new file mode 100644
index 000000000..8fe042826
--- /dev/null
+++ b/dev-java/selenium-remote-control/selenium-remote-control-1.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit java-pkg-2
+
+DESCRIPTION="Web application testing toolkit utilizing remote-control of a web browser"
+HOMEPAGE="http://seleniumhq.org/projects/remote-control/"
+SRC_URI="http://release.seleniumhq.org/${PN}/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5
+ x11-libs/libX11"
+
+src_install() {
+ java-pkg_newjar "${S}"/selenium-server-"${PV}"/selenium-server.jar
+ java-pkg_dolauncher
+}
+
+pkg_postinst() {
+ einfo "You will need a browser that selenium remote control can"
+ einfo "start and run tests. The list of supported browsers can"
+ einfo "be found here:"
+ einfo "http://seleniumhq.org/about/platforms.html#browsers"
+ einfo ""
+ einfo "Note that you must start selenium remote control within"
+ einfo "an X session of the user you intend run selenium scripts on."
+ einfo ""
+ einfo "You can use /usr/bin/selenium-remote-control to start the"
+ einfo "selenium remote control."
+}