summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Bruno (Lethalman) <lethalman88@gmail.com>2008-01-10 20:42:39 +0000
committerLuca Bruno (Lethalman) <lethalman88@gmail.com>2008-01-10 20:42:39 +0000
commit9a01a83834b5f867c399bf8daf0af2b1de2fe906 (patch)
treec704c222bc40bb9ab0c557988e6dcf43959fff34 /dev-lang/syx/syx-0.1.6.ebuild
parentnet-analyzer/symon: Fix hardcoded CC (diff)
downloadsunrise-9a01a83834b5f867c399bf8daf0af2b1de2fe906.tar.gz
sunrise-9a01a83834b5f867c399bf8daf0af2b1de2fe906.tar.bz2
sunrise-9a01a83834b5f867c399bf8daf0af2b1de2fe906.zip
dev-lang/syx: New EBuild
svn path=/sunrise/; revision=5373
Diffstat (limited to 'dev-lang/syx/syx-0.1.6.ebuild')
-rw-r--r--dev-lang/syx/syx-0.1.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/syx/syx-0.1.6.ebuild b/dev-lang/syx/syx-0.1.6.ebuild
new file mode 100644
index 000000000..95c9ccf34
--- /dev/null
+++ b/dev-lang/syx/syx-0.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Open source implementation of the Smalltalk-80 programming language."
+HOMEPAGE="http://syx.googlecode.com"
+SRC_URI="http://syx.googlecode.com/files/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp readline gtk X debug profile iprofile"
+
+RDEPEND="gmp? ( dev-libs/gmp )
+ readline? ( sys-libs/readline )
+ gtk? ( >=x11-libs/gtk+-2.12 )
+ X? ( x11-libs/libX11 )"
+
+src_compile() {
+ local myconf="$(use_enable gtk) \
+ $(use_enable readline) \
+ $(use_enable X x11)
+ $(use_enable profile)
+ $(use_enable iprofile) \
+ $(use_with gmp)"
+
+ use debug && myconf="${myconf} --enable-debug=info"
+
+ econf ${myconf} || die "Configure failed"
+
+ emake || die "Compile failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README ChangeLog TODO
+} \ No newline at end of file