summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2008-02-19 08:38:05 +0000
committerJakub Moc <jakub@gentoo.org>2008-02-19 08:38:05 +0000
commit22dd93e04ad77e505ec64d863486dcfa9a6ae8da (patch)
tree9bfd85fb0363f1c11fe5c2f64c5dfc3e2ed20c4b /dev-libs/libwiimote/libwiimote-9999.ebuild
parentmedia-sound/ogreal: Fix DEPEND (diff)
downloadsunrise-22dd93e04ad77e505ec64d863486dcfa9a6ae8da.tar.gz
sunrise-22dd93e04ad77e505ec64d863486dcfa9a6ae8da.tar.bz2
sunrise-22dd93e04ad77e505ec64d863486dcfa9a6ae8da.zip
dev-libs/libwiimote: Add missing src_compile in 0.4 to actually make use of the USE flags; econf and eautoreconf dies on its own with useful messages. Cosmetics.
svn path=/sunrise/; revision=5721
Diffstat (limited to 'dev-libs/libwiimote/libwiimote-9999.ebuild')
-rw-r--r--dev-libs/libwiimote/libwiimote-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/libwiimote/libwiimote-9999.ebuild b/dev-libs/libwiimote/libwiimote-9999.ebuild
index 37d4a2247..998b06aca 100644
--- a/dev-libs/libwiimote/libwiimote-9999.ebuild
+++ b/dev-libs/libwiimote/libwiimote-9999.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="http://libwiimote.sourceforge.net"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="examples tilt force"
+IUSE="examples force tilt"
RDEPEND="net-wireless/bluez-libs"
DEPEND="${RDEPEND}
@@ -22,14 +22,13 @@ DEPEND="${RDEPEND}
src_unpack() {
subversion_src_unpack
epatch "${FILESDIR}/${P}-ldflags.patch"
- eautoreconf || die "eautoreconf failed"
+ eautoreconf
}
src_compile() {
econf \
$(use_enable force) \
- $(use_enable tilt) \
- || die "Error: econf failed!"
+ $(use_enable tilt)
emake || die "emake failed"
}
@@ -39,6 +38,7 @@ src_install() {
dodoc AUTHORS NEWS README TODO
if use examples; then
+ docinto examples
dodoc test/test?.c
fi
}