summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-04-22 15:47:26 +0200
committerhasufell <julian.ospald@googlemail.com>2012-04-22 15:47:26 +0200
commitd8b820118d437a12af93b799b3d2b1ccce391471 (patch)
treebd6ace5d53610a4d2985af5ab0428acc5207f881 /dev-lua/luacrypto/luacrypto-0.3.1_p20120320.ebuild
parentdev-libs/libuv: relocate headers as requested per bug 410337, remove old (diff)
downloadsunrise-d8b820118d437a12af93b799b3d2b1ccce391471.tar.gz
sunrise-d8b820118d437a12af93b799b3d2b1ccce391471.tar.bz2
sunrise-d8b820118d437a12af93b799b3d2b1ccce391471.zip
dev-lua/luacrypto: version bump, new build system upstream, remove old
Diffstat (limited to 'dev-lua/luacrypto/luacrypto-0.3.1_p20120320.ebuild')
-rw-r--r--dev-lua/luacrypto/luacrypto-0.3.1_p20120320.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lua/luacrypto/luacrypto-0.3.1_p20120320.ebuild b/dev-lua/luacrypto/luacrypto-0.3.1_p20120320.ebuild
new file mode 100644
index 000000000..ce37d4ca1
--- /dev/null
+++ b/dev-lua/luacrypto/luacrypto-0.3.1_p20120320.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Lua Crypto Library"
+HOMEPAGE="https://github.com/mkottman/luacrypto.git" # most active fork
+SRC_URI="mirror://github/hasufell/tinkerbox/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_test() {
+ emake test
+}