summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Schultz <mattsch@gmail.com>2012-12-04 17:37:45 -0600
committerMatthew Schultz <mattsch@gmail.com>2012-12-04 17:37:45 -0600
commit3708108a445ec39b985e4ba473feab4489073b90 (patch)
tree7e360b55e53cd29d9e32620bf7430f498ea784fc /dev-perl/Apt-Pkg/Apt-Pkg-0.1.26.ebuild
parentsys-apps/apt: Changed udev dependency to the new virtual udev dependency. (diff)
downloadsunrise-3708108a445ec39b985e4ba473feab4489073b90.tar.gz
sunrise-3708108a445ec39b985e4ba473feab4489073b90.tar.bz2
sunrise-3708108a445ec39b985e4ba473feab4489073b90.zip
dev-perl/Apt-Pkg: New Ebuild for bug #446014. Thanks hasufell for the review.
Diffstat (limited to 'dev-perl/Apt-Pkg/Apt-Pkg-0.1.26.ebuild')
-rw-r--r--dev-perl/Apt-Pkg/Apt-Pkg-0.1.26.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Apt-Pkg/Apt-Pkg-0.1.26.ebuild b/dev-perl/Apt-Pkg/Apt-Pkg-0.1.26.ebuild
new file mode 100644
index 000000000..c7ee8dc40
--- /dev/null
+++ b/dev-perl/Apt-Pkg/Apt-Pkg-0.1.26.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit perl-module
+
+MY_PN="libapt-pkg-perl"
+
+DESCRIPTION="Perl interface to libapt-pkg"
+HOMEPAGE="http://packages.qa.debian.org/libapt-pkg-perl"
+SRC_URI="mirror://debian/pool/main/liba/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="sys-apps/apt[apt-pkg]
+ virtual/libstdc++:3.3
+ virtual/perl-Scalar-List-Utils"
+DEPEND="virtual/perl-ExtUtils-MakeMaker
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() {
+ # MakeMaker does not respect CC/CXX
+ mymake=( CC=$(tc-getCXX) )
+ perl-module_src_compile
+}
+
+src_install() {
+ perl-module_src_install
+ # Install coding examples
+ dodoc debian/changelog
+ if use examples; then
+ dodoc -r examples
+ fi
+}