summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Matejka (yac) <yac@blesmrt.net>2011-04-11 20:18:53 +0000
committerJan Matejka (yac) <yac@blesmrt.net>2011-04-11 20:18:53 +0000
commit752206bbd3e0118114ec571372455fd4dd8c2134 (patch)
tree2034fff04dec358163e4442be2a883968b11ecb8 /dev-python/Chameleon/Chameleon-2.0_rc8.ebuild
parentNow lives in gentoo-x86 (diff)
downloadsunrise-752206bbd3e0118114ec571372455fd4dd8c2134.tar.gz
sunrise-752206bbd3e0118114ec571372455fd4dd8c2134.tar.bz2
sunrise-752206bbd3e0118114ec571372455fd4dd8c2134.zip
dev-python/Chameleon: New ebuild for bug #361629
svn path=/sunrise/; revision=11885
Diffstat (limited to 'dev-python/Chameleon/Chameleon-2.0_rc8.ebuild')
-rw-r--r--dev-python/Chameleon/Chameleon-2.0_rc8.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/Chameleon/Chameleon-2.0_rc8.ebuild b/dev-python/Chameleon/Chameleon-2.0_rc8.ebuild
new file mode 100644
index 000000000..639a95873
--- /dev/null
+++ b/dev-python/Chameleon/Chameleon-2.0_rc8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.7 3"
+
+inherit distutils python
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Fast XML template compiler for Python"
+HOMEPAGE="http://chameleon.repoze.org"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="doc? ( dev-python/sphinx )"
+RDEPEND="test? ( net-zope/zope-pagetemplate
+ net-zope/zope-component
+ net-zope/zope-i18n
+ net-zope/zope-testing )"
+
+
+S="${WORKDIR}/${MY_P}"
+
+RESTRICT_PYTHON_ABIS="2.[456]"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ emake html || die "make html failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py "test"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc ; then
+ dohtml -r _build/html/* || die "dohtml failed"
+ fi
+}