summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-01-05 12:01:58 +0000
committerJakub Moc <jakub@gentoo.org>2007-01-05 12:01:58 +0000
commit6bf152c76bcf8ffefb040a2011a98e4a997a16ba (patch)
tree33170e399a8387e68080522cdf8ceb57839f7c38 /dev-python/pysvn/pysvn-1.5.0.ebuild
parentnet-zope/plonemultimedia: ebuild for bug #129180 (diff)
downloadsunrise-6bf152c76bcf8ffefb040a2011a98e4a997a16ba.tar.gz
sunrise-6bf152c76bcf8ffefb040a2011a98e4a997a16ba.tar.bz2
sunrise-6bf152c76bcf8ffefb040a2011a98e4a997a16ba.zip
dev-python/pysvn: Fix broken sed in src_unpack, fix crosscompile, add die to configure, cosmetics
svn path=/sunrise/; revision=2589
Diffstat (limited to 'dev-python/pysvn/pysvn-1.5.0.ebuild')
-rw-r--r--dev-python/pysvn/pysvn-1.5.0.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-python/pysvn/pysvn-1.5.0.ebuild b/dev-python/pysvn/pysvn-1.5.0.ebuild
index 7590f80a7..26e2aca9a 100644
--- a/dev-python/pysvn/pysvn-1.5.0.ebuild
+++ b/dev-python/pysvn/pysvn-1.5.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils python
+inherit eutils python toolchain-funcs
DESCRIPTION="Object-oriented python bindings for subversion"
HOMEPAGE="http://pysvn.tigris.org/"
@@ -11,7 +11,7 @@ SRC_URI="http://pysvn.tigris.org/files/documents/1233/34994/${P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
+IUSE=""
DEPEND=">=dev-util/subversion-1.2.0"
RDEPEND="${DEPEND}"
@@ -25,12 +25,15 @@ src_unpack() {
# no kerberos linkage
epatch "${FILESDIR}/${P}-nokrb.patch"
- python setup.py configure
+ python setup.py configure || die "configure failed"
# we want our CFLAGS as well and don't need krb linkage
sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
-e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
- -i ${S}/Source/Makefile
+ -e "/^CCC=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -i Makefile \
+ || die "sed failed in Makefile"
}
src_install() {
@@ -42,11 +45,8 @@ src_install() {
insinto /usr/lib/python${PYVER}/site-packages/pysvn
doins __init__.py
- if use doc ; then
- cd "${S}/../Docs"
- dohtml *.html *.js
- fi
-
+ cd "${S}/../Docs"
+ dohtml *.html *.js
}
pkg_postinst() {