summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Marturana (luca89) <lucamarturana@gmail.com>2006-12-09 15:42:42 +0000
committerLuca Marturana (luca89) <lucamarturana@gmail.com>2006-12-09 15:42:42 +0000
commit0870a4efb26f5a6bc195c1942b1cb22545bab5d0 (patch)
tree572b97c9658bff943843969efc0688ee33f042dc /dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
parentx11-themes/serenity: Version bump to 1.6 (diff)
downloadsunrise-0870a4efb26f5a6bc195c1942b1cb22545bab5d0.tar.gz
sunrise-0870a4efb26f5a6bc195c1942b1cb22545bab5d0.tar.bz2
sunrise-0870a4efb26f5a6bc195c1942b1cb22545bab5d0.zip
dev-python/python-libtorrent: Added a sed trick to correct paths of boost libraries
svn path=/sunrise/; revision=2180
Diffstat (limited to 'dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild')
-rw-r--r--dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild b/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
index 47cc08d71..2610c00bc 100644
--- a/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
+++ b/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
@@ -24,3 +24,13 @@ pkg_setup() {
die "Missing threads USE-flag for dev-libs/boost"
fi
}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Adding boost libraries suffix, see
+ # http://deluge-torrent.org/trac/ticket/62
+ # for details
+ sed -i -e "s:\('boost_[^']*\):\1-mt:g" setup.py
+}