summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2006-12-04 10:53:27 +0000
committerRaúl Porcel <armin76@gentoo.org>2006-12-04 10:53:27 +0000
commitafadad98e5cfd3c5e6cd1ab08bdfe190b5515524 (patch)
tree51bb2f9815dba91755d11a6f298eacdd196e6101 /dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
parentnet-p2p/deluge: Fix paths && remove dodir (diff)
downloadsunrise-afadad98e5cfd3c5e6cd1ab08bdfe190b5515524.tar.gz
sunrise-afadad98e5cfd3c5e6cd1ab08bdfe190b5515524.tar.bz2
sunrise-afadad98e5cfd3c5e6cd1ab08bdfe190b5515524.zip
dev-python/python-libtorrent: Need boost with threads USE-flag
svn path=/sunrise/; revision=2093
Diffstat (limited to 'dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild')
-rw-r--r--dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild b/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
index d4af2730a..546354f9d 100644
--- a/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
+++ b/dev-python/python-libtorrent/python-libtorrent-0.4.0.ebuild
@@ -17,3 +17,11 @@ S="${WORKDIR}/${PN}"
DEPEND=">=dev-lang/python-2.3
dev-libs/boost"
RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/boost threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+}
+