summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2009-11-18 19:21:30 +0000
committerJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2009-11-18 19:21:30 +0000
commit6e42bddecb6d5faffdbe91accd7e623e79c5bbfa (patch)
tree1649458ebbc083ee19d78171e41d857b846e1fed /dev-python/pytyrant
parentx11-misc/swarp: HOMEPAGE fixed (diff)
downloadsunrise-6e42bddecb6d5faffdbe91accd7e623e79c5bbfa.tar.gz
sunrise-6e42bddecb6d5faffdbe91accd7e623e79c5bbfa.tar.bz2
sunrise-6e42bddecb6d5faffdbe91accd7e623e79c5bbfa.zip
dev-python/pytyrant: New ebuild for bug 288330. Thanks to Fauli
svn path=/sunrise/; revision=9529
Diffstat (limited to 'dev-python/pytyrant')
-rw-r--r--dev-python/pytyrant/ChangeLog8
-rw-r--r--dev-python/pytyrant/Manifest5
-rw-r--r--dev-python/pytyrant/files/return_test_status.patch14
-rw-r--r--dev-python/pytyrant/metadata.xml5
-rw-r--r--dev-python/pytyrant/pytyrant-1.1.17.ebuild33
5 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pytyrant/ChangeLog b/dev-python/pytyrant/ChangeLog
new file mode 100644
index 000000000..f1db0b84f
--- /dev/null
+++ b/dev-python/pytyrant/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/pytyrant
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 18 Nov 2009; Johan Bergström (jbergstroem) <bugs@bergstroem.nu>
+ +pytyrant-1.1.17.ebuild, +files/return_test_status.patch, +metadata.xml:
+ New ebuild for bug 288330. Thanks to Fauli
+
diff --git a/dev-python/pytyrant/Manifest b/dev-python/pytyrant/Manifest
new file mode 100644
index 000000000..1d9b8a9ae
--- /dev/null
+++ b/dev-python/pytyrant/Manifest
@@ -0,0 +1,5 @@
+AUX return_test_status.patch 309 RMD160 10fe3f382e02eab2fd81b492b66ea7ac0d868562 SHA1 1c18683b52d25c04e7dd376bf4c28e98dd4736a9 SHA256 6be35391b40801058b556c9c8807a88fb12bca50ad5311731dbacf72d45a59b3
+DIST pytyrant-1.1.17.tar.gz 5054 RMD160 f5ef4a151eb1cc08ac956d6683bcd496a36df87d SHA1 44e15e0e6dd196f1c8a4401542d5f5214a7a146f SHA256 f53e542c6e65e7fb439223b5eda8d03f1774b96d59a4081f1fcb9b52d82c1fbb
+EBUILD pytyrant-1.1.17.ebuild 694 RMD160 4fde8d78271c51d19813a718e981020ea9158be1 SHA1 bcc29ad2bd54849b5e37b21ddcb74f208e6b5da2 SHA256 46e5025b81542b38638c0497ef3000c0053de44312bf93784eaa9be2317ce171
+MISC ChangeLog 308 RMD160 85f91cca43e81195348692af90602f66ce292170 SHA1 cebf365de21c7da82f7902705a41f3fa7020cc13 SHA256 520699219eaec831adb773002678de5938aa2b8a4f4424d70c9fe68f986f62fc
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-python/pytyrant/files/return_test_status.patch b/dev-python/pytyrant/files/return_test_status.patch
new file mode 100644
index 000000000..349b10714
--- /dev/null
+++ b/dev-python/pytyrant/files/return_test_status.patch
@@ -0,0 +1,14 @@
+--- pytyrant.py 2009-03-13 07:58:17.000000000 +0100
++++ pytyrant.py.new 2009-10-09 17:43:07.000000000 +0200
+@@ -512,8 +512,10 @@
+
+
+ def main():
++ import sys
+ import doctest
+- doctest.testmod()
++ n_fail, n_run = doctest.testmod()
++ sys.exit(int(bool(n_fail)))
+
+
+ if __name__ == '__main__':
diff --git a/dev-python/pytyrant/metadata.xml b/dev-python/pytyrant/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/dev-python/pytyrant/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/dev-python/pytyrant/pytyrant-1.1.17.ebuild b/dev-python/pytyrant/pytyrant-1.1.17.ebuild
new file mode 100644
index 000000000..0968aa41a
--- /dev/null
+++ b/dev-python/pytyrant/pytyrant-1.1.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python bindings for tokyo tyrant"
+HOMEPAGE="http://code.google.com/p/pytyrant/"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
+DOCS="README"
+
+src_prepare() {
+ epatch "${FILESDIR}/return_test_status.patch"
+}
+
+src_test() {
+ einfo "${PN} tests require a running instance of tokyo tyrant at port 1978"
+ testing() {
+ "$(PYTHON)" ${PN}.py || die "Tests failed"
+ }
+ python_execute_function testing
+}