summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-09-04 20:15:06 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-09-04 20:15:06 +0000
commitdcd5e098b5a1dc4c4f632aa3397d05bc824dd644 (patch)
treec89d7358f7efacd8ca4fc98c4509110cf95de0bb /dev-python/pyyaml/pyyaml-3.04.ebuild
parentkde-misc/cpuinfo: Version bump. (diff)
downloadsunrise-dcd5e098b5a1dc4c4f632aa3397d05bc824dd644.tar.gz
sunrise-dcd5e098b5a1dc4c4f632aa3397d05bc824dd644.tar.bz2
sunrise-dcd5e098b5a1dc4c4f632aa3397d05bc824dd644.zip
dev-python/pyyaml: Version bump.
svn path=/sunrise/; revision=1134
Diffstat (limited to 'dev-python/pyyaml/pyyaml-3.04.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-3.04.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-3.04.ebuild b/dev-python/pyyaml/pyyaml-3.04.ebuild
new file mode 100644
index 000000000..85f5ad909
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-3.04.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+MY_P=${P/pyyaml/PyYAML}
+
+DESCRIPTION="PyYAML is a YAML parser and emitter for the Python programming language."
+HOMEPAGE="http://pyyaml.org/"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+ if use examples ; then
+ insinto /usr/share/pyyaml
+ doins -r examples
+ fi
+}