summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2009-09-24 08:00:14 +0000
committerJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2009-09-24 08:00:14 +0000
commitbc731153ee10887c3439e0c48f035522fa390aa1 (patch)
treedebc5e8d9032ae6469900de39eb08d0e40587019 /dev-python/subvertpy/subvertpy-0.6.9.ebuild
parentapp-misc/dvtm: Bump to 0.5.2, propagate unicode-related builds system changes (diff)
downloadsunrise-bc731153ee10887c3439e0c48f035522fa390aa1.tar.gz
sunrise-bc731153ee10887c3439e0c48f035522fa390aa1.tar.bz2
sunrise-bc731153ee10887c3439e0c48f035522fa390aa1.zip
dev-python/subvertpy: Version bump
svn path=/sunrise/; revision=9283
Diffstat (limited to 'dev-python/subvertpy/subvertpy-0.6.9.ebuild')
-rw-r--r--dev-python/subvertpy/subvertpy-0.6.9.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/subvertpy/subvertpy-0.6.9.ebuild b/dev-python/subvertpy/subvertpy-0.6.9.ebuild
new file mode 100644
index 000000000..5be157fdc
--- /dev/null
+++ b/dev-python/subvertpy/subvertpy-0.6.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Alternative Python bindings for Subversion"
+HOMEPAGE="http://samba.org/~jelmer/subvertpy"
+SRC_URI="http://samba.org/~jelmer/${PN}/${P}.tar.gz"
+
+IUSE="examples test"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-util/subversion-1.4
+ dev-lang/python"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if ! use test ; then
+ epatch "${FILESDIR}/remove_tests.patch"
+ fi
+}
+
+src_test() {
+ cd build/lib.*/${PN}/tests || die "Tests failed"
+ nosetests || die "Tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ insinto "/usr/share/doc/${PF}"
+ if use examples; then
+ doins -r examples || die "Install Failed"
+ fi
+}