summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2010-05-15 17:57:41 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2010-05-15 17:57:41 +0000
commit3e8c7ec47d5063525778e9db4be44743b58b5af2 (patch)
treec3e2f1c8ef69c46893916c9e8ca778309fa98096 /dev-python/ubuntuone-storage-protocol
parentdev-python/django-haystack: Add explicit python inherit. (diff)
downloadsunrise-3e8c7ec47d5063525778e9db4be44743b58b5af2.tar.gz
sunrise-3e8c7ec47d5063525778e9db4be44743b58b5af2.tar.bz2
sunrise-3e8c7ec47d5063525778e9db4be44743b58b5af2.zip
dev-python/ubuntuone-storage-protocol: New Ebuild for bug 319857
svn path=/sunrise/; revision=10562
Diffstat (limited to 'dev-python/ubuntuone-storage-protocol')
-rw-r--r--dev-python/ubuntuone-storage-protocol/ChangeLog8
-rw-r--r--dev-python/ubuntuone-storage-protocol/Manifest4
-rw-r--r--dev-python/ubuntuone-storage-protocol/metadata.xml6
-rw-r--r--dev-python/ubuntuone-storage-protocol/ubuntuone-storage-protocol-1.2.0.ebuild27
4 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/ubuntuone-storage-protocol/ChangeLog b/dev-python/ubuntuone-storage-protocol/ChangeLog
new file mode 100644
index 000000000..22ff0dc5b
--- /dev/null
+++ b/dev-python/ubuntuone-storage-protocol/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/ubuntuone-storage-protocol
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 15 May 2010; Maxim (maksbotan) <kolmax94@gmail.com>
+ +ubuntuone-storage-protocol-1.2.0.ebuild, +metadata.xml:
+ New Ebuild for bug 319857
+
diff --git a/dev-python/ubuntuone-storage-protocol/Manifest b/dev-python/ubuntuone-storage-protocol/Manifest
new file mode 100644
index 000000000..97b6df518
--- /dev/null
+++ b/dev-python/ubuntuone-storage-protocol/Manifest
@@ -0,0 +1,4 @@
+DIST ubuntuone-storage-protocol-1.2.0.tar.gz 77464 RMD160 ff67eb83fcb38b5bc32c0968e8eccf52d42e1b9d SHA1 e1fc8b3a0b122ba6de8edba8a798cda3a0f7831d SHA256 008f743bba6179135dbf6b220350b70bda14bfaa9b0adf98fe253f48edc964e4
+EBUILD ubuntuone-storage-protocol-1.2.0.ebuild 606 RMD160 19a44af6d8af5456ea8d71b58994442d9ef34c8c SHA1 086d3ce46a7c047e1fe1f522eac7b82be08f2a1d SHA256 016a4b28600716971d6d8a0be3e74eadf1fcc406a9e3132b9f05957315eaa5dd
+MISC ChangeLog 280 RMD160 ec9a366f10e133eafca7577ab6e08a8d53dd6458 SHA1 5a52430b04c3ca724afd1266f32f297555630f30 SHA256 96950da3a9fd5d8a74edc20344ac2030086f0f9fcf6651c3b372cf6afa82ae4c
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/dev-python/ubuntuone-storage-protocol/metadata.xml b/dev-python/ubuntuone-storage-protocol/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/dev-python/ubuntuone-storage-protocol/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-python/ubuntuone-storage-protocol/ubuntuone-storage-protocol-1.2.0.ebuild b/dev-python/ubuntuone-storage-protocol/ubuntuone-storage-protocol-1.2.0.ebuild
new file mode 100644
index 000000000..07bf79ac0
--- /dev/null
+++ b/dev-python/ubuntuone-storage-protocol/ubuntuone-storage-protocol-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+PYTHON_DEPEND="2:2.6"
+
+inherit distutils python
+
+DESCRIPTION="Storage protocol for Ubuntu One cloud file hosting"
+HOMEPAGE="http://launchpad.net/ubuntuone-storage-protocol"
+SRC_URI="http://launchpad.net/${PN}/trunk/lucid-final/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/protobuf[python]
+ dev-python/pyopenssl
+ dev-python/pyxdg
+ dev-python/twisted
+ dev-python/oauth"