summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2010-10-05 20:54:47 +0000
committerNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2010-10-05 20:54:47 +0000
commit62e9f3fac9c3c9066b1effe851656a02ac4b2524 (patch)
tree148ecf86edbc962bf9c8ad806e3809d4d697d4b3 /dev-ruby/chronic/chronic-0.2.3.ebuild
parentdev-libs/libdbf: Avoid file name collision for endian.h (diff)
downloadsunrise-62e9f3fac9c3c9066b1effe851656a02ac4b2524.tar.gz
sunrise-62e9f3fac9c3c9066b1effe851656a02ac4b2524.tar.bz2
sunrise-62e9f3fac9c3c9066b1effe851656a02ac4b2524.zip
dev-ruby/chronic: Migrate to from gem.eclass to ruby-fakegem.eclass. Add test to RESTRICT because they fail and upstream hasn't done anything even though it's a serious bug. Add ~amd64 keyword.
(Portage version: 2.2_rc88-r1/svn/Linux x86_64) svn path=/sunrise/; revision=11403
Diffstat (limited to 'dev-ruby/chronic/chronic-0.2.3.ebuild')
-rw-r--r--dev-ruby/chronic/chronic-0.2.3.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/dev-ruby/chronic/chronic-0.2.3.ebuild b/dev-ruby/chronic/chronic-0.2.3.ebuild
index efcd5869f..e187368b8 100644
--- a/dev-ruby/chronic/chronic-0.2.3.ebuild
+++ b/dev-ruby/chronic/chronic-0.2.3.ebuild
@@ -2,16 +2,27 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
+
USE_RUBY="ruby18"
-inherit gems
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
DESCRIPTION="A pure Ruby natural language date parser"
HOMEPAGE="http://chronic.rubyforge.org"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="dev-ruby/hoe"
-DEPEND="${RDEPEND}"
+# case 1 of the following bugreport fails for me, yet the working
+# parts of the module must still be useful...
+# http://rubyforge.org/tracker/index.php?func=detail&aid=28310&group_id=2115&atid=8245
+# --binki
+RESTRICT="test"
+
+ruby_add_bdepend "dev-ruby/hoe"
+ruby_add_bdepend "doc? ( virtual/ruby-rdoc )"