summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2008-10-10 17:01:54 +0000
committerThomas Sachau <tommy@gentoo.org>2008-10-10 17:01:54 +0000
commit9bf1144c0e46be3b1fab02f401d17678960e301f (patch)
treec9b3b89efd9f7a54a5fe12ed477354e01aebd75a /dev-util/tinyxml/tinyxml-2.5.3.ebuild
parentmedia-video/elltube: version bump, remove old (diff)
downloadsunrise-9bf1144c0e46be3b1fab02f401d17678960e301f.tar.gz
sunrise-9bf1144c0e46be3b1fab02f401d17678960e301f.tar.bz2
sunrise-9bf1144c0e46be3b1fab02f401d17678960e301f.zip
dev-util/tinyxml: Add ebuild for latest version (untested)
svn path=/sunrise/; revision=7216
Diffstat (limited to 'dev-util/tinyxml/tinyxml-2.5.3.ebuild')
-rw-r--r--dev-util/tinyxml/tinyxml-2.5.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/tinyxml/tinyxml-2.5.3.ebuild b/dev-util/tinyxml/tinyxml-2.5.3.ebuild
new file mode 100644
index 000000000..acea3018b
--- /dev/null
+++ b/dev-util/tinyxml/tinyxml-2.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple C++ XML parser that can be easily integrating into other programs"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV//./_}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc examples"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -fPIC -c -o tinystr.os -DTIXML_USE_STL tinystr.cpp || die
+$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -fPIC -c -o tinyxml.os -DTIXML_USE_STL tinyxml.cpp || die
+$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -fPIC -c -o tinyxmlerror.os tinyxmlerror.cpp || die
+$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -fPIC -c -o tinyxmlparser.os -DTIXML_USE_STL tinyxmlparser.cpp || die
+$(tc-getCXX) ${CFLAGS} ${LDFLAGS} -fPIC -Wl,-soname -Wl,tinyxml.so -o libtinyxml.so -shared tinystr.os tinyxml.os tinyxmlerror.os tinyxmlparser.os || die
+ if use doc ; then
+ doxygen dox || die "doxygen failed"
+ fi
+}
+
+src_install () {
+ insinto /usr/include
+ doins *.h || die "installing headers failed"
+ dolib libtinyxml.so || die "installing library failed"
+ dodoc {changes,readme}.txt
+ if use doc ; then
+ dohtml docs/* || die "installing docs"
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/samples
+ doins *.xml xmltest.cpp || die "installing examples"
+ fi
+}