summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2010-05-17 17:07:03 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2010-05-17 17:07:03 +0000
commit9511221716c28ca7d79e4191c8623071e904cc01 (patch)
treedcd337037341b3ba8d9bf29e90cc60219a070cd3 /dev-util
parentgames-action/lugaru: Fixes hg fetch issue. Thx to reagentoo for noticing the ... (diff)
downloadsunrise-9511221716c28ca7d79e4191c8623071e904cc01.tar.gz
sunrise-9511221716c28ca7d79e4191c8623071e904cc01.tar.bz2
sunrise-9511221716c28ca7d79e4191c8623071e904cc01.zip
dev-util/depot_tools: New ebuild for bug 320227
svn path=/sunrise/; revision=10572
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/depot_tools/ChangeLog8
-rw-r--r--dev-util/depot_tools/Manifest3
-rw-r--r--dev-util/depot_tools/depot_tools-9999.ebuild41
-rw-r--r--dev-util/depot_tools/metadata.xml6
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/depot_tools/ChangeLog b/dev-util/depot_tools/ChangeLog
new file mode 100644
index 000000000..5208942ef
--- /dev/null
+++ b/dev-util/depot_tools/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-util/depot_tools
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 17 May 2010; Maxim (maksbotan) <kolmax94@gmail.com>
+ +depot_tools-9999.ebuild, +metadata.xml:
+ New ebuild for bug 320227
+
diff --git a/dev-util/depot_tools/Manifest b/dev-util/depot_tools/Manifest
new file mode 100644
index 000000000..626b77643
--- /dev/null
+++ b/dev-util/depot_tools/Manifest
@@ -0,0 +1,3 @@
+EBUILD depot_tools-9999.ebuild 1203 RMD160 c4e2b745e21785c24ff21f56b472d5cfd4d626bb SHA1 170b59f49088ea67de52ada02806c31ee16f5754 SHA256 15df655122743a8b780914276006f65f712501480046bd33a13c388804558799
+MISC ChangeLog 247 RMD160 27bdc7472a5b0016ff66e324d49559bbb49982d9 SHA1 ae7e91c23cb88d59ba4abb81f2ae85647ca12165 SHA256 4802599ec196379fff89d9bd3d078e59a286da0a879b0fadfa65ead27889c389
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/dev-util/depot_tools/depot_tools-9999.ebuild b/dev-util/depot_tools/depot_tools-9999.ebuild
new file mode 100644
index 000000000..e79dcc59c
--- /dev/null
+++ b/dev-util/depot_tools/depot_tools-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+ESVN_REPO_URI="http://src.chromium.org/svn/trunk/tools/depot_tools"
+PYTHON_DEPEND="2"
+
+inherit eutils python subversion
+
+DESCRIPTION="Scripts to manage integration with Chromium repository and development process"
+HOMEPAGE="http://dev.chromium.org/developers/how-tos/depottools"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=dev-vcs/git-1.6.6[curl]"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r \
+ git_cl_hooks.py presubmit_canned_checks.py breakpad.py \
+ PRESUBMIT.py gclient.py gclient_scm.py \
+ WATCHLISTS gclient_utils.py codereview.settings weekly scm.py \
+ tests zsh-goodies third_party || die "install failed"
+ exeinto /opt/${PN}
+ local exes="chrome-update.py cpplint.py create-chromium-git-src \
+ drover drover.py gcl gcl.py gclient git-cl \
+ git-cl-upload-hook git-gs git-try hammer \
+ presubmit_support.py trychange.py watchlists.py wtf"
+ doexe ${exes} || die "install failed"
+ for i in ${exes}
+ do
+ make_wrapper $i /opt/${PN}/$i "" "" /opt/bin || die "make_wrapper failed"
+ done
+ dodoc README README.gclient || die "dodoc failed"
+}
diff --git a/dev-util/depot_tools/metadata.xml b/dev-util/depot_tools/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/dev-util/depot_tools/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>