summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-06 13:38:42 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-06 13:38:42 +0000
commit79853e12a773c79331a3eff246f4658631df6ec8 (patch)
tree3af2a770d3f5f95ef0e05a1ced7b7954f585316b /dev-vcs/smartsvn
parentdev-lang/ squirrel: Drop squirel since I added it to tree (diff)
downloadsunrise-79853e12a773c79331a3eff246f4658631df6ec8.tar.gz
sunrise-79853e12a773c79331a3eff246f4658631df6ec8.tar.bz2
sunrise-79853e12a773c79331a3eff246f4658631df6ec8.zip
sunrise/ dev-vcs: moved stuff from dev-util to dev-vcs
svn path=/sunrise/; revision=10244
Diffstat (limited to 'dev-vcs/smartsvn')
-rw-r--r--dev-vcs/smartsvn/ChangeLog24
-rw-r--r--dev-vcs/smartsvn/Manifest4
-rw-r--r--dev-vcs/smartsvn/metadata.xml6
-rw-r--r--dev-vcs/smartsvn/smartsvn-6.5.4.ebuild48
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-vcs/smartsvn/ChangeLog b/dev-vcs/smartsvn/ChangeLog
new file mode 100644
index 000000000..9a89a0c78
--- /dev/null
+++ b/dev-vcs/smartsvn/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for dev-util/smartsvn
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 27 Feb 2010; Nikos Nikolaou (nxnikos) <nikos@nikolaou.name>
+ -smartsvn-6.0.9.ebuild, +smartsvn-6.5.4.ebuild:
+ version bump, extra svg icon, ok to commit by Tommy[D]
+
+ 08 Dec 2009; Nikos Nikolaou (nxnikos) <nikos@nikolaou.name>
+ -smartsvn-6.0.5.ebuild, +smartsvn-6.0.9.ebuild:
+ version bump
+
+ 13 Sep 2009; Nikos Nikolaou (nxnikos) <nikos@nikolaou.name>
+ -smartsvn-6.0.2.ebuild, +smartsvn-6.0.5.ebuild:
+ Version bump commit ok by bonsaikitten
+
+ 05 Jun 2009; Nikos Nikolaou (nxnikos) <nikos@nikolaou.name>
+ -smartsvn-5.0.5.ebuild, +smartsvn-6.0.2.ebuild:
+ Version bump and few changes to include java-pkg-2
+
+ 10 Apr 2009; Nikos Nikolaou (nxnikos) <nikos@nikolaou.name>
+ +smartsvn-5.0.5.ebuild, +metadata.xml:
+ New ebuild for smartsvn, bug 183325, review by Tommy[D]
+
diff --git a/dev-vcs/smartsvn/Manifest b/dev-vcs/smartsvn/Manifest
new file mode 100644
index 000000000..8a6ea0ded
--- /dev/null
+++ b/dev-vcs/smartsvn/Manifest
@@ -0,0 +1,4 @@
+DIST smartsvn-generic-6_5_4.tar.gz 10461669 RMD160 2334be41458d45c41ef5064dd9bea3ae87e6b27d SHA1 addc979ea7de85e20f104ecc8464e12867f4ad54 SHA256 8fdbe672dbb743adb69b2f28e12a4a23caba10f1d66b4d1e672fb2749ca780e2
+EBUILD smartsvn-6.5.4.ebuild 1217 RMD160 9578471631e97de77e8091a6b60716bb223cedf5 SHA1 48dac2e72ff0fe0a53908386ae1402cd262a1a1a SHA256 31e4c84234be8e9d9763b1bd6ea1e43c7f885180d83177fe729746e4d02dd2f7
+MISC ChangeLog 898 RMD160 c449010ddb02114115f4ba8da99201a109981680 SHA1 581bce962545ca7574690f13f908ec28f35f53e6 SHA256 6198d01e480b1e28d8a6adc19b57d92f4ab60f2c3543edf64a4d0ea958145cf8
+MISC metadata.xml 263 RMD160 29af7f646812a941362d89c0ee9566150df25b5b SHA1 8d5988faa6a2e1b34ca739895d1b425ddafcb32e SHA256 1a4b794f9b03c548e77abf998b34c58b16e852d255bf0322f34b48554c003c30
diff --git a/dev-vcs/smartsvn/metadata.xml b/dev-vcs/smartsvn/metadata.xml
new file mode 100644
index 000000000..ede0c5e35
--- /dev/null
+++ b/dev-vcs/smartsvn/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <longdescription>SmartSVN is a powerful GUI SVN client written in Java</longdescription>
+</pkgmetadata>
diff --git a/dev-vcs/smartsvn/smartsvn-6.5.4.ebuild b/dev-vcs/smartsvn/smartsvn-6.5.4.ebuild
new file mode 100644
index 000000000..58e526f71
--- /dev/null
+++ b/dev-vcs/smartsvn/smartsvn-6.5.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils java-pkg-2
+
+MY_PV=${PV//./_}
+MY_P=smartsvn-generic-${MY_PV}
+
+DESCRIPTION="SmartSVN"
+HOMEPAGE="http://www.syntevo.com/smartsvn/"
+SRC_URI="${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="smartsvn"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND=">=virtual/jre-1.4.1"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ local rdir="/opt/${PN}"
+ insinto ${rdir}
+ doins -r * || die "cannot install needed files"
+
+ java-pkg_regjar ${rdir}/lib/${PN}.jar
+
+ java-pkg_dolauncher ${PN} "--java-args -Xmx256 --jar ${PN}.jar"
+
+ for X in 32 48 64 128
+ do
+ insinto /usr/share/icons/hicolor/${X}x${X}/apps
+ newins "${S}/bin/${PN}-${X}.png" "${PN}.png" || die "cannot install needed files"
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins "${S}/bin/${PN}.svg" "${PN}.svg" || die "cannot install needed files"
+ done
+
+ make_desktop_entry "${PN}" "SmartSVN" ${PN} "Development;RevisionControl" || die "cannot create desktop entry"
+}
+
+pkg_nofetch(){
+ einfo "Please download ${MY_P}.tar.gz from:"
+ einfo "${HOMEPAGE}download.html?file=smartsvn/${MY_P}.tar.gz"
+ einfo "and move/copy to ${DISTDIR}"
+}