summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-03-26 22:40:28 +0000
committerhasufell <julian.ospald@googlemail.com>2012-03-26 22:40:28 +0000
commitf55c1933846caaffe8233ae68d02faee29e61d2e (patch)
tree39f9106ba76d30b6586cfda5bb0c95070ab1aca4 /games-arcade/meandmyshadow/files/meandmyshadow-0.3-cmake.patch
parentUppercase f in Free Software (diff)
downloadsunrise-f55c1933846caaffe8233ae68d02faee29e61d2e.tar.gz
sunrise-f55c1933846caaffe8233ae68d02faee29e61d2e.tar.bz2
sunrise-f55c1933846caaffe8233ae68d02faee29e61d2e.zip
games-arcade/meandmyshadow: New Ebuild for bug 408811 thanks to barul Enlik chithead
svn path=/sunrise/; revision=12842
Diffstat (limited to 'games-arcade/meandmyshadow/files/meandmyshadow-0.3-cmake.patch')
-rw-r--r--games-arcade/meandmyshadow/files/meandmyshadow-0.3-cmake.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-arcade/meandmyshadow/files/meandmyshadow-0.3-cmake.patch b/games-arcade/meandmyshadow/files/meandmyshadow-0.3-cmake.patch
new file mode 100644
index 000000000..7c8a9e178
--- /dev/null
+++ b/games-arcade/meandmyshadow/files/meandmyshadow-0.3-cmake.patch
@@ -0,0 +1,31 @@
+# fix for modifiable directories
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -85,8 +85,13 @@
+ ${CRYPTO_LIBRARY}
+ )
+
+-install(DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION share/meandmyshadow/)
+-install(TARGETS meandmyshadow RUNTIME DESTINATION bin)
++set(MEANDMYSHADOW_EXECUTABLE_DIR "bin" CACHE STRING "Path that represents the directory with meandmyshadow executable, CMAKE_INSTALL_PREFIX gets prepended")
++set(MEANDMYSHADOW_DATA_DIR "share/meandmyshadow/data" CACHE STRING "Path that represents the directory with meandmyshadow data, CMAKE_INSTALL_PREFIX gets prepended")
++
++# install locations
++install(DIRECTORY ${PROJECT_SOURCE_DIR}/data DESTINATION "${MEANDMYSHADOW_DATA_DIR}/meandmyshadow")
++install(TARGETS meandmyshadow RUNTIME DESTINATION "${MEANDMYSHADOW_EXECUTABLE_DIR}")
++
+ if("${CMAKE_SYSTEM_NAME}" MATCHES "Linux")
+ install(FILES meandmyshadow.desktop DESTINATION share/applications/)
+ install(FILES icons/16x16/meandmyshadow.png DESTINATION share/icons/hicolor/16x16/apps/)
+--- src/config.h.in
++++ src/config.h.in
+@@ -4,7 +4,7 @@
+ #if defined(WIN32)
+ //#define DATA_PATH
+ #else
+-#define DATA_PATH "@CMAKE_INSTALL_PREFIX@/share/meandmyshadow/data/"
++#define DATA_PATH "@CMAKE_INSTALL_PREFIX@/@MEANDMYSHADOW_DATA_DIR@/meandmyshadow/data/"
+ #endif
+
+ #endif