summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Szymaniak <lazy_bum@o2.pl>2011-11-28 20:38:59 +0000
committerPiotr Szymaniak <lazy_bum@o2.pl>2011-11-28 20:38:59 +0000
commit852b1e0562f276a3a484f5cae1c375bd558c8b97 (patch)
tree7e3295bd70195eebf86b54a056a6bdf23064e9a2 /games-arcade/snake/snake-0.5.2.ebuild
parentmedia-sound/gogglesmm: Changing DEPEND to fox:1.6, in advance of fox:1.7 unma... (diff)
downloadsunrise-852b1e0562f276a3a484f5cae1c375bd558c8b97.tar.gz
sunrise-852b1e0562f276a3a484f5cae1c375bd558c8b97.tar.bz2
sunrise-852b1e0562f276a3a484f5cae1c375bd558c8b97.zip
games-arcade/snake: Version bump, minor ebuild and Makefile patch fixes.
svn path=/sunrise/; revision=12538
Diffstat (limited to 'games-arcade/snake/snake-0.5.2.ebuild')
-rw-r--r--games-arcade/snake/snake-0.5.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-arcade/snake/snake-0.5.2.ebuild b/games-arcade/snake/snake-0.5.2.ebuild
new file mode 100644
index 000000000..dcdcf5f3e
--- /dev/null
+++ b/games-arcade/snake/snake-0.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils games toolchain-funcs
+
+DESCRIPTION="snake like game"
+HOMEPAGE="http://www.hs.no-ip.info/software/snake.html"
+SRC_URI="http://www.hs.no-ip.info/software/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="media-libs/libsdl[alsa,X]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{clean-up-Makefile,qa-warnings}.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ prepgamesdirs
+}