summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-03-25 11:32:49 +0000
committerJakub Moc <jakub@gentoo.org>2007-03-25 11:32:49 +0000
commit5e6465d49ec31e30cb97599e7558712d7e46a521 (patch)
tree59523829ff92c0075f750e8a90744c753a80e269 /games-arcade/tuxanci/tuxanci-0.07.ebuild
parentapp-antivirus/xfprot: Version bump, nuke old (diff)
downloadsunrise-5e6465d49ec31e30cb97599e7558712d7e46a521.tar.gz
sunrise-5e6465d49ec31e30cb97599e7558712d7e46a521.tar.bz2
sunrise-5e6465d49ec31e30cb97599e7558712d7e46a521.zip
games-arcade/tuxanci: New ebuild, created by myself
svn path=/sunrise/; revision=3280
Diffstat (limited to 'games-arcade/tuxanci/tuxanci-0.07.ebuild')
-rw-r--r--games-arcade/tuxanci/tuxanci-0.07.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-arcade/tuxanci/tuxanci-0.07.ebuild b/games-arcade/tuxanci/tuxanci-0.07.ebuild
new file mode 100644
index 000000000..dfdfd175c
--- /dev/null
+++ b/games-arcade/tuxanci/tuxanci-0.07.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games toolchain-funcs
+
+DESCRIPTION="First Cushion Shooter! A remake of well-known Czech game Bulanci."
+SRC_URI="http://tuxanci.tuxportal.cz/releases/${P}.tar.bz2"
+HOMEPAGE="http://tuxanci.tuxportal.cz"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # quick fix for English localization
+ sed -i -e "s/End game/Quit!/" lang/en.lang || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed."
+ dodoc README ChangeLog
+ prepgamesdirs
+}