summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-10-26 19:38:22 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-10-26 19:38:22 +0000
commit56f70e8a7877a7c4445fbe5ead841c1b5989f928 (patch)
tree9597386c3702905900ad05fde83b14ebab2b44d2 /games-arcade/tuxanci/tuxanci-0.20.ebuild
parentdev-embedded/s51dude: New ebuild for s51dude. Bug 241662 (diff)
downloadsunrise-56f70e8a7877a7c4445fbe5ead841c1b5989f928.tar.gz
sunrise-56f70e8a7877a7c4445fbe5ead841c1b5989f928.tar.bz2
sunrise-56f70e8a7877a7c4445fbe5ead841c1b5989f928.zip
Remove, i will put it to the tree when tomorow there will be new release.
svn path=/sunrise/; revision=7266
Diffstat (limited to 'games-arcade/tuxanci/tuxanci-0.20.ebuild')
-rw-r--r--games-arcade/tuxanci/tuxanci-0.20.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/games-arcade/tuxanci/tuxanci-0.20.ebuild b/games-arcade/tuxanci/tuxanci-0.20.ebuild
deleted file mode 100644
index 92088faca..000000000
--- a/games-arcade/tuxanci/tuxanci-0.20.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit games cmake-utils
-
-DESCRIPTION="Tuxanci is first cushion shooter based on well-known Czech game Bulanci."
-HOMEPAGE="http://www.tuxanci.org/"
-SRC_URI="http://download.${PN}.org/${PV}/${P}-src.tar.bz2"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="alsa dedicated"
-# alsa is used only when building client
-
-DEPEND="!dedicated? (
- >=media-libs/libsdl-1.2.10
- >=media-libs/sdl-ttf-2.0.7
- >=media-libs/sdl-image-1.2.6-r1
- alsa? (
- >=media-libs/sdl-mixer-1.2.7
- )
- )"
-
-S="${WORKDIR}/pkgs/${P}-src/"
-
-pkg_setup() {
- games_pkg_setup
-
- if ! built_with_use media-libs/sdl-image png ; then
- eerror "media-libs/sdl-image is missing png support."
- die "Recompile media-libs/sdl-image with USE=\"png\""
- fi
-
- if ! built_with_use media-libs/sdl-mixer vorbis ; then
- eerror "media-libs/sdl-mixer is missing vorbis support."
- die "Recompile media-libs/sdl-mixer with USE=\"vorbis\""
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # setting proper prefix
- sed -i \
- -e "s:PATH_DIR\tPREFIX:PATH_DIR:" src/base/path.h \
- || die "sed config.h failed!"
- sed -i \
- -e "s:share/tuxanci:"${GAMES_DATADIR}"/"${PN}":" src/base/path.h \
- || die "sed config.h failed!"
- sed -i \
- -e "s:CMAKE_INSTALL_DATADIR share/:CMAKE_INSTALL_DATADIR /usr/share/games/:" CMakeLists.txt \
- || die "sed CMakeLists.txt failed!"
-}
-
-src_compile() {
- local mycmakeargs
- use alsa || mycmakeargs="${mycmakeargs} -DNO_Audio=1"
- use dedicated && mycmakeargs="${mycmakeargs} -DServer=1"
- mycmakeargs="${mycmakeargs} -DPREFIX=\\\"/usr/games\\\" -DCMAKE_INSTALL_PREFIX:PATH=/usr/games"
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
- prepgamesdirs
-}