summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Pani (thpani) <thomas.pani@gmail.com>2007-12-16 09:42:06 +0000
committerThomas Pani (thpani) <thomas.pani@gmail.com>2007-12-16 09:42:06 +0000
commitcc64215d8f385988986c53f9bc6fa17800a688d4 (patch)
tree5981c12a73834755985daff9c37a35068f0a5d38 /games-board
parentnet-p2p/freenet/freenet-0.7.1090.ebuild: New upstream release (diff)
downloadsunrise-cc64215d8f385988986c53f9bc6fa17800a688d4.tar.gz
sunrise-cc64215d8f385988986c53f9bc6fa17800a688d4.tar.bz2
sunrise-cc64215d8f385988986c53f9bc6fa17800a688d4.zip
games-board/pokerth: bump to 0.6
svn path=/sunrise/; revision=5281
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/ChangeLog4
-rw-r--r--games-board/pokerth/Manifest4
-rw-r--r--games-board/pokerth/pokerth-0.6.ebuild50
3 files changed, 57 insertions, 1 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index a82746b91..f152c823f 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Dec 2007; Thomas Pani (thpani) <thomas.pani@gmail.com>
+ +pokerth-0.6.ebuild:
+ bump to 0.6
+
04 Dec 2007; Jakub Moc <jakub@gentoo.org> pokerth-0.5.ebuild:
Switch to EAPI-1 and slotted deps
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
index d82a65b03..d6394ad3d 100644
--- a/games-board/pokerth/Manifest
+++ b/games-board/pokerth/Manifest
@@ -1,4 +1,6 @@
DIST PokerTH-0.5-src.tar.bz2 4123606 RMD160 d322aecd9c44d301bb3c3ba3fc7c33bf6a6114db SHA1 344a1afcef123d4947e39e667fb310160a985958 SHA256 a521aa9f4e47741c132ce5023b07e594ee267d1b3d99fa9b5e0d78b39502239d
+DIST PokerTH-0.6-src.tar.bz2 4276312 RMD160 bcad8b7a8da012734f52e3461ac03d55512e8b02 SHA1 04657e85eb6fb01324f1680ef0ca8d0769b0c6b3 SHA256 2b149e359be287b1e37e1dff8a696f4619e258cd20041c906942e37fa2b83751
EBUILD pokerth-0.5.ebuild 1438 RMD160 2050c0e3dce835468b9b2959e58cae9a0febd8e1 SHA1 ba1709905eedc18ba8a3464d62cff2202c0a0a3d SHA256 2044f0e1b35a81fae5c74065844a45af3cfb3bcd8727ed4bbf99d4e18fdc47ec
-MISC ChangeLog 640 RMD160 f4bb942a1a085f7dd74e093399ca05bfa477cc11 SHA1 69643e5972f3bbe92c21ca6a4475c17817a0d7ef SHA256 294557594e5f2b39f87c28684307c026a913f7f9d2a92b762bff46e053ed055d
+EBUILD pokerth-0.6.ebuild 1051 RMD160 a7b4ae1f5d3a545137a66fffc0e4c4cb9ceae310 SHA1 f94cf419f3d87e2e88b94af3f9c09648178ec083 SHA256 99f5543cc535d4a159fbd150fb3a9dc024afe28fe242d1b522c27f623469eaf1
+MISC ChangeLog 738 RMD160 4f290023f005735850bb3cc1bd7a62623a65e79e SHA1 1ab4a9bf0aeab7ef874fad1e6621f602ae773e8c SHA256 de30602e703ace187a89ffd88d23c6b34d74adf23a822f8b7820732f58079054
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-board/pokerth/pokerth-0.6.ebuild b/games-board/pokerth/pokerth-0.6.ebuild
new file mode 100644
index 000000000..84bebf82c
--- /dev/null
+++ b/games-board/pokerth/pokerth-0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+inherit eutils games qt4
+
+MY_PN="PokerTH"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DESCRIPTION="Texas Hold'em poker game."
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-4.3.2:4
+ >=dev-libs/boost-1.34.1
+ >=dev-libs/openssl-0.9.7
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! built_with_use "media-libs/sdl-mixer" mikmod ; then
+ eerror "media-libs/sdl-mixer has to be compiled with USE=mikmod"
+ die "Needed USE-flag for sdl-mixer not found."
+ fi
+
+ games_pkg_setup
+}
+
+src_compile() {
+ eqmake4
+ emake || die "emake failed."
+}
+
+src_install() {
+ dogamesbin pokerth || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data || die "doins failed"
+
+ newicon pokerth.png "${PN}.png"
+ make_desktop_entry "${PN}" "PokerTH" "${PN}.png"
+
+ prepgamesdirs
+}