summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2009-07-27 16:10:51 +0000
committerMichał Górny <mgorny@gentoo.org>2009-07-27 16:10:51 +0000
commit44f32cc2c3a75431536ac1009cbd2ca8201c22a8 (patch)
tree9ee005230fe024571ddbd5eb105c0725de964984 /games-emulation/mupen64plus/files
parentNew license used by dev-db/mongodb (diff)
downloadsunrise-44f32cc2c3a75431536ac1009cbd2ca8201c22a8.tar.gz
sunrise-44f32cc2c3a75431536ac1009cbd2ca8201c22a8.tar.bz2
sunrise-44f32cc2c3a75431536ac1009cbd2ca8201c22a8.zip
games-emulation/mupen64plus: Ebuild for games-emulation/mupen64plus (bug #215426). Thanks to all Bugzilla thread contributors.
svn path=/sunrise/; revision=8889
Diffstat (limited to 'games-emulation/mupen64plus/files')
-rw-r--r--games-emulation/mupen64plus/files/mupen64plus-1.5-glide64-gcc44.patch24
-rw-r--r--games-emulation/mupen64plus/files/mupen64plus-1.5-plugindir.patch13
-rw-r--r--games-emulation/mupen64plus/files/mupen64plus-1.5-unbundle-bzip2.patch38
3 files changed, 75 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus/files/mupen64plus-1.5-glide64-gcc44.patch b/games-emulation/mupen64plus/files/mupen64plus-1.5-glide64-gcc44.patch
new file mode 100644
index 000000000..c11f103c6
--- /dev/null
+++ b/games-emulation/mupen64plus/files/mupen64plus-1.5-glide64-gcc44.patch
@@ -0,0 +1,24 @@
+diff -dupr Mupen64Plus-1-5-src.old/glide64/Combine.cpp Mupen64Plus-1-5-src/glide64/Combine.cpp
+--- Mupen64Plus-1-5-src.old/glide64/Combine.cpp 2009-01-04 19:47:08.000000000 +0100
++++ Mupen64Plus-1-5-src/glide64/Combine.cpp 2009-07-27 16:54:40.737065400 +0200
+@@ -11873,7 +11873,7 @@ void InitCombine ()
+ LOG ("InitCombine() ");
+ memset(&cmb, 0, sizeof(cmb));
+ const char *extensions = grGetString (GR_EXTENSION);
+- if (char * extstr = strstr(extensions, "COMBINE")) {
++ if (const char * extstr = strstr(extensions, "COMBINE")) {
+ if (!strncmp(extstr, "COMBINE", 7)) {
+ LOG ("extensions ");
+ cmb.grColorCombineExt = (GRCOLORCOMBINEEXT) grGetProcAddress("grColorCombineExt");
+diff -dupr Mupen64Plus-1-5-src.old/glide64/Main.cpp Mupen64Plus-1-5-src/glide64/Main.cpp
+--- Mupen64Plus-1-5-src.old/glide64/Main.cpp 2009-07-27 16:49:30.596192066 +0200
++++ Mupen64Plus-1-5-src/glide64/Main.cpp 2009-07-27 16:49:42.492067819 +0200
+@@ -784,7 +784,7 @@ BOOL InitGfx (BOOL evoodoo_using_window)
+ printf("bebefore2\n");
+ if (settings.fb_hires)
+ {
+- if (char * extstr = strstr(extensions, "TEXTUREBUFFER"))
++ if (const char * extstr = strstr(extensions, "TEXTUREBUFFER"))
+ {
+ if (!strncmp(extstr, "TEXTUREBUFFER", 13))
+ {
diff --git a/games-emulation/mupen64plus/files/mupen64plus-1.5-plugindir.patch b/games-emulation/mupen64plus/files/mupen64plus-1.5-plugindir.patch
new file mode 100644
index 000000000..96363547a
--- /dev/null
+++ b/games-emulation/mupen64plus/files/mupen64plus-1.5-plugindir.patch
@@ -0,0 +1,13 @@
+diff -dupr Mupen64Plus-1-5-src.orig/main/main.c Mupen64Plus-1-5-src/main/main.c
+--- Mupen64Plus-1-5-src.orig/main/main.c 2009-05-01 09:18:21.387785870 +0200
++++ Mupen64Plus-1-5-src/main/main.c 2009-05-01 09:20:10.998784906 +0200
+@@ -1476,8 +1476,7 @@ int main(int argc, char *argv[])
+ // if it's not set in the config file, use the /plugins/ sub-folder of the installation directory
+ if (strlen(dirpath) < 2)
+ {
+- strncpy(dirpath, l_InstallDir, PATH_MAX);
+- strncat(dirpath, "plugins/", PATH_MAX - strlen(dirpath));
++ strncpy(dirpath, "%PUT_PLUGIN_PATH_HERE%", PATH_MAX);
+ dirpath[PATH_MAX-1] = '\0';
+ }
+ // scan the plugin directory and set the config dir for the plugins
diff --git a/games-emulation/mupen64plus/files/mupen64plus-1.5-unbundle-bzip2.patch b/games-emulation/mupen64plus/files/mupen64plus-1.5-unbundle-bzip2.patch
new file mode 100644
index 000000000..9ed10be85
--- /dev/null
+++ b/games-emulation/mupen64plus/files/mupen64plus-1.5-unbundle-bzip2.patch
@@ -0,0 +1,38 @@
+diff -dupr Mupen64Plus-1-5-src.old/Makefile Mupen64Plus-1-5-src/Makefile
+--- Mupen64Plus-1-5-src.old/Makefile 2009-01-04 19:47:07.000000000 +0100
++++ Mupen64Plus-1-5-src/Makefile 2009-07-27 17:12:55.984193344 +0200
+@@ -111,13 +111,6 @@ OBJ_CORE = \
+ main/savestates.o \
+ main/zip/ioapi.o \
+ main/zip/unzip.o \
+- main/bzip2/bzlib.o \
+- main/bzip2/crctable.o \
+- main/bzip2/decompress.o \
+- main/bzip2/compress.o \
+- main/bzip2/randtable.o \
+- main/bzip2/huffman.o \
+- main/bzip2/blocksort.o \
+ main/lzma/buffer.o \
+ main/lzma/io.o \
+ main/lzma/main.o \
+@@ -246,7 +239,7 @@ SHARE = $(shell grep CONFIG_PATH config.
+ # set primary objects and libraries for all outputs
+ ALL = mupen64plus $(PLUGINS)
+ OBJECTS = $(OBJ_CORE) $(OBJ_DYNAREC) $(OBJ_OPENGL)
+-LIBS = $(SDL_LIBS) $(LIBGL_LIBS)
++LIBS = $(SDL_LIBS) $(LIBGL_LIBS) -lbz2
+
+ # add extra objects and libraries for selected options
+ ifeq ($(DBG), 1)
+diff -dupr Mupen64Plus-1-5-src.old/main/rom.c Mupen64Plus-1-5-src/main/rom.c
+--- Mupen64Plus-1-5-src.old/main/rom.c 2009-01-04 19:47:07.000000000 +0100
++++ Mupen64Plus-1-5-src/main/rom.c 2009-07-27 17:29:55.918067662 +0200
+@@ -28,7 +28,7 @@
+ #include <zlib.h>
+
+ #include "zip/unzip.h"
+-#include "bzip2/bzlib.h"
++#include <bzlib.h>
+ #include "lzma/lzmadec.h"
+ #include "7zip/7zExtract.h"
+ #include "7zip/7zCrc.h"