summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Cendron <scen@gentoo.org>2007-06-07 19:01:57 +0000
committerDavide Cendron <scen@gentoo.org>2007-06-07 19:01:57 +0000
commit65353847f1a646f1aa1800233732ba34f018ee09 (patch)
tree7efbb9a5920b54c787ce61c12df25e15c65a4150 /games-fps
parentnew USE flags for games-fps/vavoom (diff)
downloadsunrise-65353847f1a646f1aa1800233732ba34f018ee09.tar.gz
sunrise-65353847f1a646f1aa1800233732ba34f018ee09.tar.bz2
sunrise-65353847f1a646f1aa1800233732ba34f018ee09.zip
games-fps/vavoom: New ebuild for bug 132055, thanks to Paul Bredbury and #gentoo-sunrise guys
svn path=/sunrise/; revision=3823
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/vavoom/ChangeLog8
-rw-r--r--games-fps/vavoom/Manifest4
-rw-r--r--games-fps/vavoom/metadata.xml10
-rw-r--r--games-fps/vavoom/vavoom-1.23.1.ebuild242
4 files changed, 264 insertions, 0 deletions
diff --git a/games-fps/vavoom/ChangeLog b/games-fps/vavoom/ChangeLog
new file mode 100644
index 000000000..a7df4942d
--- /dev/null
+++ b/games-fps/vavoom/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-fps/vavoom
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 07 Jun 2007; Davide Cendron (scen) <scen@gentoo.org>
+ +vavoom-1.23.1.ebuild, +metadata.xml:
+ New ebuild for bug 132055, thanks to Paul Bredbury and #gentoo-sunrise guys
+
diff --git a/games-fps/vavoom/Manifest b/games-fps/vavoom/Manifest
new file mode 100644
index 000000000..a01311f24
--- /dev/null
+++ b/games-fps/vavoom/Manifest
@@ -0,0 +1,4 @@
+DIST vavoom-1.23.1.tar.bz2 1694668 RMD160 e41cfe48efe428eb6a6eaf218117f910d2083e79 SHA1 05f04ba44a384b7caf9e0490dd8e949035dbf5d6 SHA256 85d95ff9fda0dc0c2e4a106cefaf849f2409a1e57c04c3a9a046fedc25c5f390
+EBUILD vavoom-1.23.1.ebuild 6447 RMD160 069620cea446d0196c73b418cdb84a6ce0c0ef66 SHA1 e880a6656c970fdc75fc8eacfa1e03247a75bf42 SHA256 28bc43369f31b734057787f659418d63fd71bc0ba22730cd5285acd30b528956
+MISC ChangeLog 291 RMD160 e04f8eae86635aac659e62fdf882f31311d18dce SHA1 59135fd85c292a7dc441c8d85cbe1a414e1cedbf SHA256 8af6ec13d249b3e9a5d0c6b1c54d1a2e3d7c8febb0889ad0f73684ffd74996c4
+MISC metadata.xml 303 RMD160 626272995441b20fd23b1d0a94603e98b97b0f1e SHA1 f3cae1ec3568e7717d7265a58d0b2e6d8efe88b5 SHA256 334d9b64af3b010a9fcdcbd8736eba2f81ff9d87dee3eb76b5adacb7d48afa37
diff --git a/games-fps/vavoom/metadata.xml b/games-fps/vavoom/metadata.xml
new file mode 100644
index 000000000..43f59ffac
--- /dev/null
+++ b/games-fps/vavoom/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd></herd>
+ <longdescription lang="en">
+ Vavoom is a source port based on sources of Doom, Heretic, Hexen and a
+ little bit from Quake
+</longdescription>
+</pkgmetadata>
+
diff --git a/games-fps/vavoom/vavoom-1.23.1.ebuild b/games-fps/vavoom/vavoom-1.23.1.ebuild
new file mode 100644
index 000000000..5a20759a4
--- /dev/null
+++ b/games-fps/vavoom/vavoom-1.23.1.ebuild
@@ -0,0 +1,242 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools eutils flag-o-matic games
+
+DESCRIPTION="Advanced source port for Doom/Heretic/Hexen/Strife"
+HOMEPAGE="http://www.vavoom-engine.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="allegro debug dedicated external-glbsp flac mad mikmod models music
+openal opengl sdl textures tools vorbis"
+
+QA_EXECSTACK="${GAMES_BINDIR:1}/${PN}"
+
+# From econf: "Vavoom requires Allegro or SDL to compile"
+# SDL,like Allegro are *software* renderers in this game.
+# So, if not selected through proper USEs, the default is SDL,
+# without opengl (vavoom can run in software-mode only).
+# To enable it, enable proper USE.
+# OpenGL is the normally-desired hardware renderer, selected on command-line
+# (through "-opengl" switch). This switch is also added to the desktop entry,
+# if "opengl" USE flag is enabled
+
+SDLDEPEND=">=media-libs/libsdl-1.2
+ media-libs/sdl-mixer"
+ALLEGDEPEND=">=media-libs/allegro-4.0"
+OPENGLDEPEND="opengl? ( virtual/opengl )
+ sdl? ( ${SDLDEPEND} )
+ allegro? ( media-libs/allegrogl )
+ !sdl? ( !allegro? ( ${SDLDEPEND} ) )"
+DEPEND="media-libs/libpng
+ media-libs/jpeg
+ sdl? ( ${SDLDEPEND} )
+ !sdl? ( allegro? ( ${ALLEGDEPEND} ) )
+ !sdl? ( !allegro? ( !dedicated? ( ${OPENGLDEPEND} ) ) )
+ opengl? ( ${OPENGLDEPEND} )
+ vorbis? ( media-libs/libvorbis )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libmad )
+ mikmod? ( media-libs/libmikmod )
+ openal? ( media-libs/openal )
+ external-glbsp? ( games-util/glbsp )"
+RDEPEND="${DEPEND}
+ allegro? ( media-sound/timidity++ )"
+PDEPEND="models? ( >=games-fps/vavoom-models-1.4 )
+ music? ( games-fps/vavoom-music )
+ textures? ( games-fps/vavoom-textures )"
+
+dir=${GAMES_DATADIR}/${PN}
+
+pkg_setup() {
+ local backend="media-libs/libsdl"
+
+ if ! use sdl && use allegro ; then
+ backend="media-libs/allegro"
+ fi
+
+ games_pkg_setup
+
+ # Do some important check ...
+
+ if use sdl && use allegro ; then
+ echo
+ ewarn "Both 'allegro' and 'sdl' USE flags enabled"
+ ewarn "Set default to SDL"
+ elif ! use sdl && ! use allegro ; then
+ ewarn "Both 'sdl' and 'allegro' USE flags disabled"
+ ewarn "Set default to SDL"
+ fi
+
+ # Base graphic/sound/music support is enabled?
+
+ echo
+ einfo "Doing some sanity check..."
+
+ # Graphic check
+ if ! built_with_use ${backend} X ; then
+ echo
+ eerror "Software Graphic support is not configured properly!"
+ eerror "Please rebuild ${backend} with 'X' USE flag enabled"
+ die "graphic support error"
+ fi
+
+ # Sound check
+ if ! built_with_use ${backend} alsa ; then
+ echo
+ eerror "Sound support is not configured properly!"
+ eerror "Please rebuild ${backend} with 'alsa' USE flag enabled"
+ die "sound support error"
+ fi
+
+ # Music check
+ if ! use allegro && ! built_with_use media-libs/sdl-mixer timidity ; then
+ echo
+ eerror "MIDI Music support is not configured properly!"
+ eerror "Please rebuild sdl-mixer with USE 'timidity' enabled!"
+ die "music support error"
+ fi
+
+ # OpenGL check
+ if use opengl ; then
+ if [ "${backend}" == "media-libs/libsdl" ] && ! built_with_use ${backend} opengl ; then
+ echo
+ eerror "OpenGL support is not configured properly!"
+ eerror "Please rebuild ${backend} with 'opengl' USE flag enabled"
+ die "opengl support error"
+ fi
+ else
+ echo
+ ewarn "'opengl' USE flag disabled. OpenGL is recommended, for best graphics."
+ fi
+
+ # Does user want external music? Vorbis support is needed
+ if use music && ! use vorbis ; then
+ echo
+ eerror "Ogg/Vorbis support is required for external music playing"
+ eerror "Please enable 'vorbis' USE flag for this package"
+ die "external music support error"
+ fi
+
+ echo
+ einfo "All is OK, let's build!"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Set shared directory
+ sed -i \
+ -e "s:fl_basedir = \".\":fl_basedir = \"${dir}\":" \
+ source/files.cpp || die "sed files.cpp failed"
+
+ eautoreconf
+
+ # Set executable filenames
+ for m in $(find . -type f -name Makefile.in) ; do
+ sed -i \
+ -e "s:MAIN_EXE = @MAIN_EXE@:MAIN_EXE=${PN}:" \
+ -e "s:SERVER_EXE = @SERVER_EXE@:SERVER_EXE=${PN}-ded:" \
+ "${m}" || die "sed ${m} failed"
+ done
+}
+
+src_compile() {
+ local \
+ allegro="--without-allegro" \
+ sdl="--without-sdl"
+
+ # Sdl is the default, unless sdl=off & allegro=on
+ if ! use sdl && use allegro ; then
+ allegro="--with-allegro"
+ else
+ sdl="--with-sdl"
+ fi
+
+ use debug && append-flags -g2
+
+ egamesconf \
+ --enable-client \
+ ${sdl} \
+ ${allegro} \
+ $(use_with opengl) \
+ $(use_with openal) \
+ $(use_with external-glbsp) \
+ $(use_with vorbis) \
+ $(use_with mad libmad) \
+ $(use_with mikmod) \
+ $(use_with flac) \
+ $(use_enable dedicated server) \
+ $(use_enable debug) \
+ $(use_enable debug zone-debug) \
+ --with-iwaddir="${dir}" \
+ --disable-dependency-tracking \
+ || die "egamesconf failed"
+
+ # Parallel compiling doesn't work for now :(
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ local de_cmd="${PN}"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Remove unneeded icon
+ rm -f "${D}/${dir}/${PN}.png"
+
+ doicon source/${PN}.png || die "doicon failed"
+
+ # Enable OpenGL in desktop entry, if relevant USE flag is enabled
+ use opengl && de_cmd="${PN} -opengl"
+ make_desktop_entry "${de_cmd}" "Vavoom"
+
+ #if use dedicated ; then
+ # dogamesbin ${PN}-ded || die "dogamesbin ${PN}-ded failed"
+ #fi
+
+ dodoc docs/${PN}.txt || die "dodoc vavoom.txt failed"
+
+ if use tools; then
+ # The tools are always built
+ dobin utils/bin/{acc,fixmd2,vcc,vlumpy} || die "dobin utils failed"
+ dodoc utils/vcc/vcc.txt || die "dodoc vcc.txt failed"
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "Copy or link wad files into ${dir}"
+ elog "(the files must be readable by the 'games' group)."
+ elog
+ elog "Example setup:"
+ elog "ln -sn ${GAMES_DATADIR}/doom-data/doom.wad ${dir}/"
+ elog
+ elog "Example command-line:"
+ elog " vavoom -doom -opengl"
+ elog
+ elog "See documentation for further details."
+
+ if use tools; then
+ echo
+ elog "You have also installed some Vavoom-related utilities"
+ elog "(useful for mod developing):"
+ elog
+ elog " - acc (ACS Script Compiler)"
+ elog " - fixmd2 (MD2 models utility)"
+ elog " - vcc (Vavoom C Compiler)"
+ elog " - vlumpy (Vavoom Lump utility)"
+ elog
+ elog "See the Vavoom Wiki at http://vavoom-engine.com/wiki/ or"
+ elog "Vavoom Forum at http://www.vavoom-engine.com/forums/"
+ elog "for further help."
+ fi
+}