summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Berntsen <alexanderberntsen@linux.com>2012-04-24 14:55:59 +0200
committerAlexander Berntsen <alexanderberntsen@linux.com>2012-04-24 14:55:59 +0200
commit75b91daffe667565a9e282d2be10d29aa7157514 (patch)
tree25128abe9013ddc56e050730ab7c7e81e4c4400e /games-misc/limbs-off
parentgames-action/minetest_game: New Ebuild for bug 399867 (diff)
downloadsunrise-75b91daffe667565a9e282d2be10d29aa7157514.tar.gz
sunrise-75b91daffe667565a9e282d2be10d29aa7157514.tar.bz2
sunrise-75b91daffe667565a9e282d2be10d29aa7157514.zip
games-misc/limbs-off: Add alpha1 and fix various issues with 9999
Diffstat (limited to 'games-misc/limbs-off')
-rw-r--r--games-misc/limbs-off/ChangeLog10
-rw-r--r--games-misc/limbs-off/Manifest5
-rw-r--r--games-misc/limbs-off/limbs-off-1.0_alpha1.ebuild50
-rw-r--r--games-misc/limbs-off/limbs-off-9999.ebuild28
4 files changed, 81 insertions, 12 deletions
diff --git a/games-misc/limbs-off/ChangeLog b/games-misc/limbs-off/ChangeLog
index 62162b23d..9eefa1f7b 100644
--- a/games-misc/limbs-off/ChangeLog
+++ b/games-misc/limbs-off/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*limbs-off-1.0_alpha1 (24 Apr 2012)
+
+ 24 Apr 2012; Alexander Berntsen (alexander__b) <alexanderberntsen@linux.com>
+ +limbs-off-1.0_alpha1.ebuild, limbs-off-9999.ebuild:
+ Add alpha1 and fix various issues with 9999
+
19 Apr 2012; Alexander Berntsen (alexander__b) <alexanderberntsen@linux.com>
limbs-off-9999.ebuild:
Add dodoc TODO
@@ -10,10 +16,6 @@
limbs-off-9999.ebuild:
Uppercase f in Free Software
- 26 Mar 2012; Alexander Berntsen (alexander__b) <alexanderberntsen@linux.com>
- limbs-off-9999.ebuild:
- Uppercase f in Free Software
-
19 Mar 2012; Alexander Berntsen (alexander__b) <alexanderberntsen@linux.com>
limbs-off-9999.ebuild:
Update description to include that the game is gratis
diff --git a/games-misc/limbs-off/Manifest b/games-misc/limbs-off/Manifest
index a736958d9..06348d34b 100644
--- a/games-misc/limbs-off/Manifest
+++ b/games-misc/limbs-off/Manifest
@@ -1,3 +1,4 @@
-EBUILD limbs-off-9999.ebuild 537 RMD160 0c84dcd06f443f98efebba63de70b58689b3a05b SHA1 f67a7c213c64521dd168c69e9033cc3b1c171793 SHA256 a6a574beed79234353de278d3702ada8d5f82625b96fef33b3ad527112d453f0
-MISC ChangeLog 982 RMD160 bfb2509ca93f6b4ae0af2b79e3357518162701f2 SHA1 7e770fd5d3240bd744294e355072b0b2fb746890 SHA256 125ec512f52421967e7e66a7ffa9974f1a906d931d430dea3ccfc1b5ac7008a0
+EBUILD limbs-off-1.0_alpha1.ebuild 875 RMD160 f8c11783ce2629220c7ecc5b14ce5078b005bee4 SHA1 91850adab760bfc004a9d90a64951675be7dccbf SHA256 b6e40a464e9372eee80f7abd7d7eca7437a29b4b1b460f4d76e1a953aa917b79
+EBUILD limbs-off-9999.ebuild 820 RMD160 eb178a12e74bf4843ddda714e7dd378cbbe4ccda SHA1 a0fbfa6ab9ec52206052397b367053fca2d0ebdd SHA256 991803d926356375a3d6ee6ac26df21a4a2e31c962db09298ba538d672a50b0a
+MISC ChangeLog 1064 RMD160 d1fbac780a93c79f628358f0d915b823e9e9dda9 SHA1 aa1ec77cb137b4ba355dcc46d8a40b6055b4a191 SHA256 85355ba786d1f4f8d2b9cf7006a3604ec00dfc0702b682c04e495bf7484795ae
MISC metadata.xml 208 RMD160 c18611400760e42bdd001905be0a63c2e963bcea SHA1 595816105cac477cb85792a182e15888029118a1 SHA256 c4841c87f0c2b9b5e679a27dc72180be8d508fb3f5df0fbab2ec2c805c0a6d82
diff --git a/games-misc/limbs-off/limbs-off-1.0_alpha1.ebuild b/games-misc/limbs-off/limbs-off-1.0_alpha1.ebuild
new file mode 100644
index 000000000..951d97218
--- /dev/null
+++ b/games-misc/limbs-off/limbs-off-1.0_alpha1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit autotools git-2 games
+
+DESCRIPTION="Gratis Free Software fighting game"
+HOMEPAGE="http://plaimi.net/games/"
+EGIT_REPO_URI="https://github.com/stiell/${PN}.git
+ git://github.com/stiell/${PN}.git"
+EGIT_COMMIT="5cb4434e89e945d215e1f9b12ffc6e998c3367e5"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/libpng:0
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ virtual/opengl
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ "
+
+src_unpack() {
+ git-2_src_unpack
+}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-icondir=/usr/share/pixmaps \
+ --with-desktopdir=/usr/share/applications
+}
+
+src_install() {
+ dodoc HACKING TODO || die
+ emake DESTDIR="${D}" install || die
+ prepgamesdirs
+}
diff --git a/games-misc/limbs-off/limbs-off-9999.ebuild b/games-misc/limbs-off/limbs-off-9999.ebuild
index e89dbf45a..73fc5f4cc 100644
--- a/games-misc/limbs-off/limbs-off-9999.ebuild
+++ b/games-misc/limbs-off/limbs-off-9999.ebuild
@@ -2,13 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=3
-inherit autotools eutils git-2
+inherit autotools git-2 games
DESCRIPTION="Gratis Free Software fighting game"
HOMEPAGE="http://plaimi.net/games/"
-EGIT_REPO_URI="git://github.com/stiell/limbs-off.git"
+EGIT_REPO_URI="https://github.com/stiell/${PN}.git
+ git://github.com/stiell/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
@@ -17,17 +18,32 @@ IUSE=""
RDEPEND="
media-libs/fontconfig
- media-libs/libpng
+ media-libs/libpng:0
media-libs/libsdl
media-libs/sdl-ttf
virtual/opengl
"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ "
+
+src_unpack() {
+ git-2_src_unpack
+}
+
src_prepare() {
eautoreconf
}
+src_configure() {
+ egamesconf \
+ --with-icondir=/usr/share/pixmaps \
+ --with-desktopdir=/usr/share/applications
+}
+
src_install() {
- default
- dodoc HACKING TODO
+ dodoc HACKING TODO || die
+ emake DESTDIR="${D}" install || die
+ prepgamesdirs
}