summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-07-09 10:48:19 +0000
committerMichael Weber <xmw@gentoo.org>2010-07-09 10:48:19 +0000
commit9d8660d9132bd183d3927b6db9d715f4b2d115fd (patch)
tree9df644e3adfe48ac1d3905debfa843d55a9ccaf8 /games-puzzle/OsmosDemo
parentlicense for games-puzzle/OsmosDemo (diff)
downloadsunrise-9d8660d9132bd183d3927b6db9d715f4b2d115fd.tar.gz
sunrise-9d8660d9132bd183d3927b6db9d715f4b2d115fd.tar.bz2
sunrise-9d8660d9132bd183d3927b6db9d715f4b2d115fd.zip
games-puzzle/OsmosDemo: New ebuild for bug 327435
svn path=/sunrise/; revision=10969
Diffstat (limited to 'games-puzzle/OsmosDemo')
-rw-r--r--games-puzzle/OsmosDemo/ChangeLog8
-rw-r--r--games-puzzle/OsmosDemo/Manifest4
-rw-r--r--games-puzzle/OsmosDemo/OsmosDemo-1.6.0.ebuild49
-rw-r--r--games-puzzle/OsmosDemo/metadata.xml6
4 files changed, 67 insertions, 0 deletions
diff --git a/games-puzzle/OsmosDemo/ChangeLog b/games-puzzle/OsmosDemo/ChangeLog
new file mode 100644
index 000000000..d0d407320
--- /dev/null
+++ b/games-puzzle/OsmosDemo/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-puzzle/OsmosDemo
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 09 Jul 2010; Michael Weber (xmw) <gentoo@xmw.de> +OsmosDemo-1.6.0.ebuild,
+ +metadata.xml:
+ New ebuild for bug 327435
+
diff --git a/games-puzzle/OsmosDemo/Manifest b/games-puzzle/OsmosDemo/Manifest
new file mode 100644
index 000000000..7f3df9849
--- /dev/null
+++ b/games-puzzle/OsmosDemo/Manifest
@@ -0,0 +1,4 @@
+DIST OsmosDemo_1.6.0.tar.gz 7796374 RMD160 b069cafac15acfc8dc50efcc2a60a1be04b6415d SHA1 ed0a55d5b451c87041b2dacb846195868e91046f SHA256 ebc208652edaee4995cc55cdd1e422743462567de340b647a8dd454f853dd161
+EBUILD OsmosDemo-1.6.0.ebuild 1089 RMD160 372c73ca1ba3ccc69eb844da5af7020ecbb75a48 SHA1 81ab42bb944e6da3e2779ac28c94ba073a60bc64 SHA256 63c8bb4c6572d0640d448718361e54c9b68ecc4b17e3646a138d96e7f34c021a
+MISC ChangeLog 245 RMD160 da06b7e14a5b9468ec6713991614642c4b60ab79 SHA1 0e775403ce2077aacbc9b2a4b7372c0ae4b8464f SHA256 2924bb1589f30587c3e0a71274ab8afdd37837186ac156bd339d519815fa4ac1
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/games-puzzle/OsmosDemo/OsmosDemo-1.6.0.ebuild b/games-puzzle/OsmosDemo/OsmosDemo-1.6.0.ebuild
new file mode 100644
index 000000000..cfd5fedd8
--- /dev/null
+++ b/games-puzzle/OsmosDemo/OsmosDemo-1.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit games
+
+DESCRIPTION="Simple, ambient, nice-looking growing game"
+HOMEPAGE="http://www.hemispheregames.com/osmos/"
+SRC_URI="http://www.hemispheregames.com/blog/wp-content/uploads/2010/04/${PN}_${PV}.tar.gz"
+
+LICENSE="${PN}"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 -*"
+IUSE=""
+
+RDEPEND="media-libs/freetype
+ media-libs/libvorbis
+ media-libs/openal
+ x11-libs/libX11
+ virtual/opengl"
+
+S=${WORKDIR}/${PN}
+QA_PRESTRIPPED="/opt/OsmosDemo/OsmosDemo.bin32
+ /opt/OsmosDemo/OsmosDemo.bin64"
+
+src_prepare() {
+ rm eula.txt OsmosDemo || die
+ if use amd64 ; then
+ MY_BIN=${PN}.bin64
+ rm ${PN}.bin32 || die
+ fi
+ if use x86 ; then
+ MY_BIN=${PN}.bin32
+ rm ${PN}.bin64 || die
+ fi
+}
+
+src_install() {
+ local my_dest=/opt/${PN}
+ insinto "${my_dest}"
+ doins -r . || die
+ fperms ug+x "${my_dest}"/${MY_BIN} || die
+
+ games_make_wrapper ${PN} ./${MY_BIN} "${my_dest}"
+ make_desktop_entry "${GAMES_BINDIR}"/${PN} ${PN} "${my_dest}"/Icons/128x128.png Game
+ prepgamesdirs "${my_dest}"
+}
diff --git a/games-puzzle/OsmosDemo/metadata.xml b/games-puzzle/OsmosDemo/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/games-puzzle/OsmosDemo/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>