summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rennings (mren) <mren@mrmx.de>2009-07-05 00:15:11 +0000
committerMarkus Rennings (mren) <mren@mrmx.de>2009-07-05 00:15:11 +0000
commit549960f867bbcd5651f4f9d8324010de2cb783dd (patch)
tree1d6f9e8ad44dc0985693973fb2f2b927de321e3e /media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild
parentsys-kernel/ccs-sources: Drop DEPEND (diff)
downloadsunrise-549960f867bbcd5651f4f9d8324010de2cb783dd.tar.gz
sunrise-549960f867bbcd5651f4f9d8324010de2cb783dd.tar.bz2
sunrise-549960f867bbcd5651f4f9d8324010de2cb783dd.zip
media-gfx/fontmatrix: Version bump, slightly adjustments
svn path=/sunrise/; revision=8727
Diffstat (limited to 'media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild')
-rw-r--r--media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild b/media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild
new file mode 100644
index 000000000..f9d04b186
--- /dev/null
+++ b/media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+
+inherit cmake-utils qt4
+
+DESCRIPTION="A font manager"
+HOMEPAGE="http://www.fontmatrix.net/"
+SRC_URI="http://www.fontmatrix.net/archives/${P}-Source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-webkit:4
+ media-libs/freetype:2"
+DEPEND=${RPEDEND}
+
+S=${WORKDIR}/${P}-Source
+
+src_compile() {
+ local mycmakeargs="-DOWN_SHAPER=1"
+ cmake-utils_src_compile
+}
+
+src_install() {
+ dobin "${CMAKE_BUILD_DIR}"/src/${PN} || die
+ doman ${PN}.1 || die
+ domenu ${PN}.desktop || die
+ dodoc ChangeLog TODO || die
+}
+
+pkg_postinst() {
+ elog "If you encounter problems or just have questions or if you have"
+ elog " suggestions, please take time to suscribe to the undertype-users"
+ elog " mailing list ( https://mail.gna.org/listinfo/undertype-users )."
+ elog " If you want to reach us quickly, come to #fontmatrix at Freenode."
+}