summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2009-08-12 14:30:58 +0000
committerJustin Lecher <jlec@gentoo.org>2009-08-12 14:30:58 +0000
commit9f6bc793708c3f38ded152fa6db12992ab196138 (patch)
treeee421ed4a5db7f8d4b0fdd7b6cc06a349a34271a /media-gfx/gimp-cmyk-plugin/gimp-cmyk-plugin-0.5.4.ebuild
parentdev-python/eventlet: New version and test additions. Thanks to Tommy[D] (diff)
downloadsunrise-9f6bc793708c3f38ded152fa6db12992ab196138.tar.gz
sunrise-9f6bc793708c3f38ded152fa6db12992ab196138.tar.bz2
sunrise-9f6bc793708c3f38ded152fa6db12992ab196138.zip
media-gfx/gimp-cmyk-plugin: version bump, CC, LDFLAGS and CFLAGS are respected now, keyworded for ~amd64, make use of base.eclass
svn path=/sunrise/; revision=9003
Diffstat (limited to 'media-gfx/gimp-cmyk-plugin/gimp-cmyk-plugin-0.5.4.ebuild')
-rw-r--r--media-gfx/gimp-cmyk-plugin/gimp-cmyk-plugin-0.5.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/gimp-cmyk-plugin/gimp-cmyk-plugin-0.5.4.ebuild b/media-gfx/gimp-cmyk-plugin/gimp-cmyk-plugin-0.5.4.ebuild
new file mode 100644
index 000000000..b51b373b6
--- /dev/null
+++ b/media-gfx/gimp-cmyk-plugin/gimp-cmyk-plugin-0.5.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2007-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit base toolchain-funcs
+
+MY_P="separate+-${PV}"
+
+DESCRIPTION="Gimp CMYK plug-in."
+HOMEPAGE="http://cue.yellowmagic.info/softwares/separate.html"
+SRC_URI="mirror://sourceforge.jp/separate-plus/41810/${MY_P}.zip
+ http://download.adobe.com/pub/adobe/iccprofiles/win/AdobeICCProfilesCS4Win_end-user.zip"
+
+LICENSE="GPL-2 Adobe"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/lcms
+ media-libs/tiff
+ media-gfx/gimp"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-Makefile.patch
+ )
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ || die "compilation failed"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die "emake install failed"
+ insinto /usr/share/color/icc
+ doins -r sRGB || die "doins failed installing sRGB icc profiles"
+ cd "${WORKDIR}/Adobe ICC Profiles (end-user)"
+ doins -r CMYK RGB || die "doins failed installing Adobe CMYK and RGB icc profiles"
+}