summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Schultz (mschultz) <mattsch@gmail.com>2011-05-21 23:16:42 +0000
committerMatthew Schultz (mschultz) <mattsch@gmail.com>2011-05-21 23:16:42 +0000
commit757db95403c5f480486f1126ebf2297097090d74 (patch)
tree544e19af2e7ac284b8d114c6ed5596f302ae05af /media-gfx/iscan-plugin-gt-x770
parentdev-python/pyicu: restrict ICU version range. (diff)
downloadsunrise-757db95403c5f480486f1126ebf2297097090d74.tar.gz
sunrise-757db95403c5f480486f1126ebf2297097090d74.tar.bz2
sunrise-757db95403c5f480486f1126ebf2297097090d74.zip
media-gfx/iscan-plugin-gt-x770: New ebuild for bug 367585
svn path=/sunrise/; revision=12077
Diffstat (limited to 'media-gfx/iscan-plugin-gt-x770')
-rw-r--r--media-gfx/iscan-plugin-gt-x770/ChangeLog8
-rw-r--r--media-gfx/iscan-plugin-gt-x770/Manifest5
-rw-r--r--media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1.ebuild66
-rw-r--r--media-gfx/iscan-plugin-gt-x770/metadata.xml17
4 files changed, 96 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-gt-x770/ChangeLog b/media-gfx/iscan-plugin-gt-x770/ChangeLog
new file mode 100644
index 000000000..f91066694
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x770/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-gfx/iscan-plugin-gt-x770
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 21 May 2011; Matthew Schultz (mschultz) <mattsch@gmail.com>
+ +iscan-plugin-gt-x770-2.1.2.1.ebuild, +metadata.xml:
+ New ebuild for bug 367585
+
diff --git a/media-gfx/iscan-plugin-gt-x770/Manifest b/media-gfx/iscan-plugin-gt-x770/Manifest
new file mode 100644
index 000000000..41a26480b
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x770/Manifest
@@ -0,0 +1,5 @@
+DIST iscan-plugin-gt-x770-2.1.2-1.i386.rpm 462166 RMD160 969e558bd50730ede5cc349978ae589ae29bc4a5 SHA1 d4f49773803e5f43d0c1ac78e702bd383de259c9 SHA256 8ce99f42e302d6686f71c3e697f75ca1eb608af72d5986d785c9cf8bc4bd93fc
+DIST iscan-plugin-gt-x770-2.1.2-1.x86_64.rpm 196426 RMD160 6e1caf565a6b9eea3176a7698a5e22c9210e0c58 SHA1 7f6101f6176451753c8ba2e4d72438aa8517710e SHA256 87db6217232e0ce6ee2f50183f831fd923aaa76b34e0da7445f4cd7bcad5b902
+EBUILD iscan-plugin-gt-x770-2.1.2.1.ebuild 1768 RMD160 47a3bf90002f339865970e8c018dc954ab194541 SHA1 3fd49a2f531ecd3b83622d6e3a8f900deae7d55a SHA256 b09a4f51cb8cebe8d7b8720592786416139412be3b3be68fc22825f326aff32b
+MISC ChangeLog 277 RMD160 f731776f946a9f3eb7b0dbf71b5ef2931162f2a3 SHA1 c3ff9d0568d33164a242d1d0963eafe9c5a9a293 SHA256 2a8622a2b04524de91cbf6c075f986d32f61f90845dfcab123287fb0055748f9
+MISC metadata.xml 531 RMD160 429413007853aa3dcf2d4357d874222d4e7a3474 SHA1 3f203855bc3091f46bec5ce9caa7747ede2ef29c SHA256 bf164a8048a5cc697023ac2423508eec696494e83bb75293a98113750affae34
diff --git a/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1.ebuild b/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1.ebuild
new file mode 100644
index 000000000..9d0b85c11
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit rpm versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+MY_PV="$(get_version_component_range 1-3)"
+
+DESCRIPTION="Epson Perfection V500 scanner plugin for SANE 'epkowa' backend."
+HOMEPAGE="http://www.avasys.jp/english/linux_e/dl_scan.html"
+SRC_URI="
+ x86? ( http://linux.avasys.jp/drivers/iscan-plugins/${PN}/${MY_PV}/${MY_P}.i386.rpm )
+ amd64? ( http://linux.avasys.jp/drivers/iscan-plugins/${PN}/${MY_PV}/${MY_P}.x86_64.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=media-gfx/iscan-2.21.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+QA_PRESTRIPPED="/opt/iscan/lib/libesint7C.so.2.0.1 /opt/iscan/lib/libesint7C.so.2 /opt/iscan/lib/libesint7C.so"
+
+src_install() {
+ # install scanner firmware
+ insinto /opt/iscan/share
+ doins "${WORKDIR}"/usr/share/iscan/*
+ # install scanner plugins
+ exeinto /opt/iscan/lib
+ doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
+}
+
+pkg_setup() {
+ basecmd="iscan-registry --COMMAND interpreter usb 0x04b8 0x0130 /opt/iscan/lib/libesint7C /opt/iscan/share/esfw7C.bin"
+}
+
+pkg_postinst() {
+ [[ -n ${REPLACING_VERSIONS} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ eval ${basecmd/COMMAND/add}
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ ewarn "${basecmd/COMMAND/add}"
+ fi
+}
+
+pkg_prerm() {
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ if [[ ${ROOT} == "/" ]]; then
+ eval ${basecmd/COMMAND/remove}
+ else
+ ewarn "Unable to register the plugin and firmware when installing outside of /."
+ ewarn "execute the following command yourself:"
+ ewarn "${basecmd/COMMAND/remove}"
+ fi
+}
diff --git a/media-gfx/iscan-plugin-gt-x770/metadata.xml b/media-gfx/iscan-plugin-gt-x770/metadata.xml
new file mode 100644
index 000000000..d39f6c04f
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-x770/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models, to be used
+ with the epkowa SANE backend (provided by
+ <pkg>media-gfx/iscan</pkg>). 32-bit and 64-bit.
+
+ Supports the following models:
+
+ EPSON Perfection V500 (GT-X770)
+ </longdescription>
+</pkgmetadata>