summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2006-07-20 19:01:04 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2006-07-20 19:01:04 +0000
commitb991dc9cb0fcc84c2c697162b71d21825b95aebf (patch)
treec48a629b26769ef76b25dcceda9f29157d5a6471 /media-gfx/xaralx/xaralx-0.6_pre1479.ebuild
parentmedia-gfx/f4l: QA fixes (diff)
downloadsunrise-b991dc9cb0fcc84c2c697162b71d21825b95aebf.tar.gz
sunrise-b991dc9cb0fcc84c2c697162b71d21825b95aebf.tar.bz2
sunrise-b991dc9cb0fcc84c2c697162b71d21825b95aebf.zip
media-gfx/xaralx: New ebuild. bug #126867
svn path=/sunrise/; revision=659
Diffstat (limited to 'media-gfx/xaralx/xaralx-0.6_pre1479.ebuild')
-rw-r--r--media-gfx/xaralx/xaralx-0.6_pre1479.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-gfx/xaralx/xaralx-0.6_pre1479.ebuild b/media-gfx/xaralx/xaralx-0.6_pre1479.ebuild
new file mode 100644
index 000000000..14bb8080b
--- /dev/null
+++ b/media-gfx/xaralx/xaralx-0.6_pre1479.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils wxwidgets autotools
+
+MY_P=XaraLX-${PV/_pre/r}
+
+DESCRIPTION="Xara LX is a commercial vector graphics platform, recently made
+available on Gentoo as a free OpenSource port."
+HOMEPAGE="http://www.xaraxtreme.org"
+SRC_URI="http://downloads2.xara.com/opensource/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+
+ >=x11-libs/wxGTK-2.6.3
+ >=sys-devel/gettext-0.14.3
+ >=media-libs/libpng-1.2.8
+ >=media-libs/jpeg-6b
+ app-arch/zip
+ dev-lang/perl
+ >=dev-libs/libxml2-2.6.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ export WX_GTK_VER="2.6"
+ need-wxwidgets unicode
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-wx-config=${WX_CONFIG} --with-wx-base-config=${WX_CONFIG} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # For now installs just the bin
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon ${PN}.png
+ dodoc README
+
+ # Fix and install desktop file
+ sed -i -e "s#c=xaralx#c=XaraLX#g" ${PN}.desktop
+ domenu ${PN}.desktop
+}