summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-08-20 13:48:00 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-08-20 13:48:00 +0000
commit759140ab8324d71775559ba12b1d0d92be386eba (patch)
treeffdbe02e3ec8983d82d708c0bd05e90261882b30 /media-libs/amanith/amanith-0.3.ebuild
parentnet-misc/aria2: Building with libxml2 support only if metalink is wanted (diff)
downloadsunrise-759140ab8324d71775559ba12b1d0d92be386eba.tar.gz
sunrise-759140ab8324d71775559ba12b1d0d92be386eba.tar.bz2
sunrise-759140ab8324d71775559ba12b1d0d92be386eba.zip
media-libs/amanith: Added CXX= since it didn't respect CXX
Cosmetic cleanups Not setting +x on the examples anymore, the user should do it if needed svn path=/sunrise/; revision=969
Diffstat (limited to 'media-libs/amanith/amanith-0.3.ebuild')
-rw-r--r--media-libs/amanith/amanith-0.3.ebuild39
1 files changed, 12 insertions, 27 deletions
diff --git a/media-libs/amanith/amanith-0.3.ebuild b/media-libs/amanith/amanith-0.3.ebuild
index cb4e45382..614346852 100644
--- a/media-libs/amanith/amanith-0.3.ebuild
+++ b/media-libs/amanith/amanith-0.3.ebuild
@@ -2,27 +2,26 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+inherit eutils toolchain-funcs
+
+KEYWORDS="~amd64 ~x86"
DESCRIPTION="Crossplatform & Opensource C++ Vector Graphic Framework"
HOMEPAGE="http://www.amanith.org/blog/index.php"
SRC_URI="http://www.amanith.org/download/files/${PN}_${PV/./}.tar.gz"
-
LICENSE="QPL"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
IUSE="examples qt4"
-
DEPEND=">=media-libs/freetype-2.1.10
- >=media-libs/jpeg-6b
- >=media-libs/libpng-1.2.10
- >=sys-libs/zlib-1.2.3
- qt4? ( >=x11-libs/qt-4.1.0 )
- !qt4? ( =x11-libs/qt-3* )"
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.10
+ >=sys-libs/zlib-1.2.3
+ qt4? ( >=x11-libs/qt-4.1.0 )
+ !qt4? ( =x11-libs/qt-3* )"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
@@ -45,14 +44,13 @@ src_unpack() {
}
src_compile() {
- cd "${S}"
export AMANITHDIR="${S}"
if ! use qt4; then
export QTDIR="/usr/qt/3"
PATH="${QTDIR}/bin:${PATH}"
fi
qmake || die "qmake failed"
- emake || die "emake failed"
+ emake CXX=$(tc-getCXX) || die "emake failed"
}
src_install() {
@@ -67,23 +65,10 @@ src_install() {
doins "doc/amanith.chm"
if use examples; then
- insinto "/usr/share/${PN}"
-
# remove the object files
find ./examples -iname "*.o" -delete
- doins -r examples
- # and set the executable bit for the demos (removed by doins),
- # note: do not use 'cp -r' since every file has executable bit set
- for file in $(find "${D}/usr/share/${PN}/examples" -print); do
- if [[ -n $(readelf -s "${file}" 2>/dev/null) ]]; then
- chmod a+x ${file};
- fi
- done
-
-
- doins -r data
- doins -r config
+ insinto "/usr/share/${PN}"
+ doins -r examples data config
fi
-
}