summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Zimmermann (moHiJ) <patrick@zakweb.de>2007-03-06 20:39:45 +0000
committerPatrick Zimmermann (moHiJ) <patrick@zakweb.de>2007-03-06 20:39:45 +0000
commit909852f82649e40bf851707525085bd47bbd7157 (patch)
tree4f00487339891479c61b38d488ded3de16f97fb5 /media-libs/freeimage/freeimage-3.9.3.ebuild
parentnew USE flags for x11-plugins/gaim-plugin_pack (diff)
downloadsunrise-909852f82649e40bf851707525085bd47bbd7157.tar.gz
sunrise-909852f82649e40bf851707525085bd47bbd7157.tar.bz2
sunrise-909852f82649e40bf851707525085bd47bbd7157.zip
media-libs/freeimage: New ebuild for bug 165938 thanks to Steve Yin, foobat@gmail.com, Sergey Belyashov
svn path=/sunrise/; revision=3149
Diffstat (limited to 'media-libs/freeimage/freeimage-3.9.3.ebuild')
-rw-r--r--media-libs/freeimage/freeimage-3.9.3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/freeimage/freeimage-3.9.3.ebuild b/media-libs/freeimage/freeimage-3.9.3.ebuild
new file mode 100644
index 000000000..71bab6a84
--- /dev/null
+++ b/media-libs/freeimage/freeimage-3.9.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit multilib
+
+MY_PN=FreeImage
+MY_PV=${PV//./}
+MY_P=${MY_PN}${MY_PV}
+
+DESCRIPTION="A library project for developers who would like to support popular graphics image formats."
+HOMEPAGE="http://sourceforge.net/projects/freeimage"
+SRC_URI="mirror://sourceforge/freeimage/${MY_P}.zip
+ doc? ( mirror://sourceforge/freeimage/${MY_P}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc mmx plus"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/freeimage-3.9.3-make.patch
+}
+
+src_compile() {
+ if ! use mmx; then
+ CFLAGS="${CFLAGS} -DPNG_NO_ASSEMBLER_CODE -DPNG_NO_MMX_CODE"
+ CXXFLAGS="${CXXFLAGS} -DPNG_NO_ASSEMBLER_CODE -DPNG_NO_MMX_CODE"
+ fi
+ emake || die
+ if use plus; then
+ emake -f Makefile.fip || die
+ fi
+}
+
+src_install() {
+ dodoc README.* Whatsnew.txt
+
+ if use doc; then
+ dodoc ${WORKDIR}/${MY_P}.pdf
+ fi
+ if use plus; then
+ dodoc Wrapper/FreeImagePlus/WhatsNew_FIP.txt
+ fi
+ dolib.so Dist/*.so
+ dolib.a Dist/*.a
+ dosym /usr/$(get_libdir)/libfreeimage-${PV}.so /usr/$(get_libdir)/libfreeimage.so
+ insinto /usr/include
+ doins Dist/*.h
+}