summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorheimdall <heimdall@unknownhost.org>2006-12-21 20:27:36 +0000
committerheimdall <heimdall@unknownhost.org>2006-12-21 20:27:36 +0000
commitcf8075cb29482d7068444323308a5e14eb4b6120 (patch)
tree3c404adae723725f33b6b39749ba0beca1cc8734 /media-libs
parentmedia-libs/libinstrudeo: Tighten deps to =media-libs/libdc1394-1*; thanks to ... (diff)
downloadsunrise-cf8075cb29482d7068444323308a5e14eb4b6120.tar.gz
sunrise-cf8075cb29482d7068444323308a5e14eb4b6120.tar.bz2
sunrise-cf8075cb29482d7068444323308a5e14eb4b6120.zip
sunrise/media-libs/libinstrudeo/libinstrudeo-0.1.3.ebuild: Versien bumped for media-libs/libinstrudeo and media-video/screenkast, both to 0.1.3
svn path=/sunrise/; revision=2407
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libinstrudeo/libinstrudeo-0.1.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/libinstrudeo/libinstrudeo-0.1.3.ebuild b/media-libs/libinstrudeo/libinstrudeo-0.1.3.ebuild
new file mode 100644
index 000000000..741710bd0
--- /dev/null
+++ b/media-libs/libinstrudeo/libinstrudeo-0.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Provides the necessary logic to capture screen recordings and to process them"
+HOMEPAGE="http://libinstrudeo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-cpp/libxmlpp-2.10.0
+ >=media-libs/freetype-2.1.9
+ >=dev-libs/glib-2.10.0
+ >=dev-cpp/glibmm-2.8.4
+ media-libs/libvorbis
+ =media-libs/libdc1394-1*
+ media-libs/libdts
+ media-libs/libtheora
+ media-libs/ftgl
+ media-video/ffmpeg
+ media-sound/gsm
+ net-misc/curl
+ dev-libs/openssl
+ sys-libs/zlib
+ virtual/glut"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's#/etc/instrudeo#/usr/share/instrudeo#g' \
+ data/commentboxes/Makefile.in \
+ data/fonts/Makefile.in \
+ src/libinstrudeo/isdcommentbox.h \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}