summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-09-07 17:39:46 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-09-07 17:39:46 +0000
commit63da73f9055581f64a68d5c406cfb80bc963dad9 (patch)
tree4125a9bb49dc5f9adb2529c25707129b047bd189 /media-sound/exaile/exaile-0.2.2.ebuild
parentsys-fs/cromfs: New eBuild for bug 146694 (diff)
downloadsunrise-63da73f9055581f64a68d5c406cfb80bc963dad9.tar.gz
sunrise-63da73f9055581f64a68d5c406cfb80bc963dad9.tar.bz2
sunrise-63da73f9055581f64a68d5c406cfb80bc963dad9.zip
media-sound/exaile: Version bump.
Removed pyogg and pymad dependencies (thanks to Henrique Ferreiro García for letting me know). Added media-libs/mutagen dependency. Added sed-patch to disable the installation of the provided mutagen-files. svn path=/sunrise/; revision=1172
Diffstat (limited to 'media-sound/exaile/exaile-0.2.2.ebuild')
-rw-r--r--media-sound/exaile/exaile-0.2.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-sound/exaile/exaile-0.2.2.ebuild b/media-sound/exaile/exaile-0.2.2.ebuild
new file mode 100644
index 000000000..263496b05
--- /dev/null
+++ b/media-sound/exaile/exaile-0.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Exaile is a media player aiming to be similar to KDE's AmaroK, but for GTK"
+HOMEPAGE="http://www.exaile.org"
+SRC_URI="http://www.exaile.org/files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/pygtk-2.0"
+RDEPEND="${DEPEND}
+ >=dev-python/pysqlite-2
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-good-0.10
+ >=dev-python/gst-python-0.10
+ >=media-libs/mutagen-1.6
+ sys-apps/dbus"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use sys-apps/dbus python; then
+ eerror "dbus has to be built with python support"
+ die "dbus python use-flag not set"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/mutagen/d' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}