summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2009-04-22 14:50:04 +0000
committerChristian Ruppert <idl0r@gentoo.org>2009-04-22 14:50:04 +0000
commit10c12a9ded4fade693b24f73ad0c42dad8ec09bc (patch)
tree8be905db70a6b77b67a219e44c53b90f3b8a501f /media-sound/mtag/mtag-3.ebuild
parentwww-apps/davical: Version bump to 0.9.6.3 (diff)
downloadsunrise-10c12a9ded4fade693b24f73ad0c42dad8ec09bc.tar.gz
sunrise-10c12a9ded4fade693b24f73ad0c42dad8ec09bc.tar.bz2
sunrise-10c12a9ded4fade693b24f73ad0c42dad8ec09bc.zip
media-sound/mtag: Removed unused eutils inherit, added cmake-utils. Added missing die statements.
svn path=/sunrise/; revision=8384
Diffstat (limited to 'media-sound/mtag/mtag-3.ebuild')
-rw-r--r--media-sound/mtag/mtag-3.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/media-sound/mtag/mtag-3.ebuild b/media-sound/mtag/mtag-3.ebuild
index ecb1d9b0c..ee1e662b7 100644
--- a/media-sound/mtag/mtag-3.ebuild
+++ b/media-sound/mtag/mtag-3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+inherit cmake-utils
DESCRIPTION="the fast media tag lib"
HOMEPAGE="http://mtag.berlios.de/"
@@ -15,18 +15,14 @@ IUSE="doc"
RDEPEND="media-libs/taglib
>=dev-db/sqlite-3.3.12"
-DEPEND="dev-util/cmake
- ${RDEPEND}"
+DEPEND="${RDEPEND}"
-src_compile() {
- cmake "${S}" || die "compile failed!"
- emake || die "compile failed!"
-}
+CMAKE_IN_SOURCE_BUILD=1
src_install() {
- dobin mtag
- dodoc README ChangeLog AUTHORS
+ dobin mtag || die "dobin failed"
+ dodoc README ChangeLog AUTHORS || die "dodoc failed"
if use doc; then
- dohtml html/*
+ dohtml -r html/* || die "dohtml failed"
fi
}