summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola (ZoD) Tomassoni <zod@oziosi.org>2007-05-07 09:03:41 +0000
committerNicola (ZoD) Tomassoni <zod@oziosi.org>2007-05-07 09:03:41 +0000
commit7b05abef4cbb40a8af76f0bf9044430fa672b32c (patch)
tree814ccd90526159b2bfc7ecb31cae496778dcffc2 /media-sound/soma/soma-2.4.ebuild
parentgames-util/bsp: Added explicit RDEPEND=${DEPEND} (diff)
downloadsunrise-7b05abef4cbb40a8af76f0bf9044430fa672b32c.tar.gz
sunrise-7b05abef4cbb40a8af76f0bf9044430fa672b32c.tar.bz2
sunrise-7b05abef4cbb40a8af76f0bf9044430fa672b32c.zip
media-sound/soma: New ebuild and patch for bug 176820
svn path=/sunrise/; revision=3583
Diffstat (limited to 'media-sound/soma/soma-2.4.ebuild')
-rw-r--r--media-sound/soma/soma-2.4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-sound/soma/soma-2.4.ebuild b/media-sound/soma/soma-2.4.ebuild
new file mode 100644
index 000000000..ab39a5f7e
--- /dev/null
+++ b/media-sound/soma/soma-2.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+IUSE="ffmpeg"
+
+DESCRIPTION="Audio and video broadcast manager"
+HOMEPAGE="http://www.somasuite.org"
+SRC_URI="http://www.somasuite.org/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/openssl
+ >=sys-libs/ncurses-5.0
+ >=sys-libs/readline-5.0
+ dev-libs/libxml2
+ ffmpeg? ( media-video/ffmpeg )"
+
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-pid.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable ffmpeg) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README README.module
+}
+
+pkg_postinst() {
+ einfo " *** *** ***"
+ einfo "If you can afford to donate us some money let us know, we also need"
+ einfo "new and old working hardware."
+ einfo " "
+ einfo "you can send a mail to"
+ einfo " "
+ einfo " mail: soma@inventati.org"
+ einfo " or: bakunin@autistici.org"
+ einfo " *** *** ***"
+}