summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2007-05-10 19:39:11 +0000
committerJakub Moc <jakub@gentoo.org>2007-05-10 19:39:11 +0000
commit09ac2a8be44e3c11c62fa807d42e10153b0a3fce (patch)
treee8bcda93e2006e4e16b5724ccd6af75d196dd7f0 /media-sound/somax/somax-1.3.ebuild
parentdev-db/dabo: Nuke old (diff)
downloadsunrise-09ac2a8be44e3c11c62fa807d42e10153b0a3fce.tar.gz
sunrise-09ac2a8be44e3c11c62fa807d42e10153b0a3fce.tar.bz2
sunrise-09ac2a8be44e3c11c62fa807d42e10153b0a3fce.zip
media-sound/somax: Fix DEPEND, clean up
svn path=/sunrise/; revision=3600
Diffstat (limited to 'media-sound/somax/somax-1.3.ebuild')
-rw-r--r--media-sound/somax/somax-1.3.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/media-sound/somax/somax-1.3.ebuild b/media-sound/somax/somax-1.3.ebuild
index 2abbd9c77..e16775fcb 100644
--- a/media-sound/somax/somax-1.3.ebuild
+++ b/media-sound/somax/somax-1.3.ebuild
@@ -6,7 +6,7 @@ inherit eutils
IUSE="nls gnome"
-DESCRIPTION="Control and configure somad through somax, a graphic panel"
+DESCRIPTION="Control and configure soma through a graphic panel"
HOMEPAGE="http://www.somasuite.org"
SRC_URI="http://www.somasuite.org/src/${P}.tar.gz"
@@ -14,14 +14,15 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="media-sound/soma
+RDEPEND="media-sound/soma
>=x11-libs/gtk+-2.0
x11-libs/libSM
x11-libs/vte
- gnome? ( x11-libs/gtksourceview )
- gnome? ( >=gnome-base/libgnomeprintui-2.0 )"
+ gnome? ( x11-libs/gtksourceview
+ >=gnome-base/libgnomeprintui-2.0 )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
src_unpack() {
unpack ${A}
@@ -31,9 +32,7 @@ src_unpack() {
}
src_compile() {
- if ! use gnome;then
- myconf="${myconf} --disable-gnomeprint"
- fi
+ use gnome || myconf="${myconf} --disable-gnomeprint"
econf \
$(use_enable nls) \
@@ -43,24 +42,21 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
emake DESTDIR="${D}" install || die "make install failed"
doicon icons/somax.png
- make_desktop_entry somax SomaX somax.png AudioVideo
+ make_desktop_entry ${PN} SomaX ${PN}.png AudioVideo;GTK
- dodoc AUTHORS ChangeLog ABOUT-NLS README README.modules README.plugins README.library
+ dodoc AUTHORS ChangeLog ABOUT-NLS README README.{modules,plugins,library}
}
pkg_postinst() {
- einfo " *** *** ***"
einfo "If you can afford to donate us some money let us know, we also need"
einfo "new and old working hardware."
- einfo " "
+ einfo
einfo "you can send a mail to"
- einfo " "
+ einfo
einfo " mail: soma@inventati.org"
einfo " or: bakunin@autistici.org"
- einfo " *** *** ***"
}
-