summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEly Levy (nakee) <nakeee@gmail.com>2007-05-25 11:49:13 +0000
committerEly Levy (nakee) <nakeee@gmail.com>2007-05-25 11:49:13 +0000
commitccc819e0f96e001f8600748ab4c9d3e68151d63c (patch)
treecbaa5f7ea935e52c88dc45594c716c5f3c7bb505 /media-sound/soundkonverter
parentgnome-extra/nautilus-actions: drop old (diff)
downloadsunrise-ccc819e0f96e001f8600748ab4c9d3e68151d63c.tar.gz
sunrise-ccc819e0f96e001f8600748ab4c9d3e68151d63c.tar.bz2
sunrise-ccc819e0f96e001f8600748ab4c9d3e68151d63c.zip
media-sound/soundkonverter: New build for 107189 thanks for the guys at #gentoo-sunrise for all the help
svn path=/sunrise/; revision=3728
Diffstat (limited to 'media-sound/soundkonverter')
-rw-r--r--media-sound/soundkonverter/ChangeLog8
-rw-r--r--media-sound/soundkonverter/Manifest4
-rw-r--r--media-sound/soundkonverter/metadata.xml5
-rw-r--r--media-sound/soundkonverter/soundkonverter-0.3.3.ebuild57
4 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/soundkonverter/ChangeLog b/media-sound/soundkonverter/ChangeLog
new file mode 100644
index 000000000..432ee87e9
--- /dev/null
+++ b/media-sound/soundkonverter/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-sound/soundkonverter
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 25 May 2007; Ely Levy (nakee) <nakeee@gmail.com>
+ +soundkonverter-0.3.3.ebuild, +metadata.xml:
+ New build for 107189 thanks for the guys at #gentoo-sunrise for all the help
+
diff --git a/media-sound/soundkonverter/Manifest b/media-sound/soundkonverter/Manifest
new file mode 100644
index 000000000..00d8f8975
--- /dev/null
+++ b/media-sound/soundkonverter/Manifest
@@ -0,0 +1,4 @@
+DIST soundkonverter-0.3.3.tar.bz2 625291 RMD160 9abfce8df4e74d62a51a6c1a819a242b99f419bd SHA1 3d54797173b0431d649a6348b51cdfc4792561e9 SHA256 8fe9ce3657b7f4425c475df8bb0d8417b3fa48af246b109efbb819c49e2766ec
+EBUILD soundkonverter-0.3.3.ebuild 1511 RMD160 84958b50d4812bfda5d269bcfe22f0f07b22e415 SHA1 728452bf13110a657c9ed14bd87c0a3f62a9f117 SHA256 df61315f9f50570a23ff4a068854f8d3a03fa6ab425b871b56a64481f4fcc9c5
+MISC ChangeLog 305 RMD160 8ba9ca2929fefc01429c55c5e0251dbc34998366 SHA1 d110a60404399109bee3d0ed4e6d583e585fb548 SHA256 ed8489a5592e7cc31158c0c80286c6b45ee89d825e31f2b6b73bdbdc17431178
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/media-sound/soundkonverter/metadata.xml b/media-sound/soundkonverter/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/media-sound/soundkonverter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/media-sound/soundkonverter/soundkonverter-0.3.3.ebuild b/media-sound/soundkonverter/soundkonverter-0.3.3.ebuild
new file mode 100644
index 000000000..0fec928b5
--- /dev/null
+++ b/media-sound/soundkonverter/soundkonverter-0.3.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2003-2007 SabayonLinux
+# Copyright 2007-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit kde eutils
+
+DESCRIPTION="a frontend to various audio converters for KDE"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=29024"
+SRC_URI="http://hessijames.googlepages.com/soundkonverter-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="lame vorbis flac ffmpeg musepack kdeenablefinal arts aac"
+
+DEPEND=">=media-libs/taglib-1.4
+ >=media-sound/cdparanoia-3.9.8-r5
+ >=x11-libs/qt-3.3.4
+ aac? ( media-libs/libmp4v2 )
+ "
+
+RDEPEND="${DEPEND}
+ lame? ( >=media-sound/lame-3.96 )
+ vorbis? ( >=media-sound/vorbis-tools-1.0 )
+ flac? ( >=media-libs/flac-1.1.1 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.8 )
+ musepack? ( >=media-sound/musepack-tools-1.15u )
+ "
+
+need-kde 3.5
+
+#src_unpack() {
+# kde_src_unpack
+#}
+
+src_compile() {
+# append-flags -fno-inline
+ local myconf="$(use_with aac mp4v2)
+ $(use_enable kdeenablefinal final)
+ $(use_with arts arts)"
+ kde_src_compile || die "Compile error"
+}
+
+src_install() {
+ kde_src_install || die "Installation failed"
+ mv "${D}"/usr/share/doc/HTML "${D}"/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ echo
+ elog " The audio USE flags are for your convience, but are not required."
+ elog " For AmaroK users there is a script included with this package."
+ elog " You can enable it with the Script Manager tool in Amarok."
+ echo
+}
+