summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2009-01-18 17:32:02 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2009-01-18 17:32:02 +0000
commit154e7e8cd66f896dae4f4c3f4391bdbcf802e917 (patch)
tree9b46895b00d1d51e38b560ca32e6f9d5ce7a29ae /media-sound
parentgames-fps/uhexen2: Little cleanup (diff)
downloadsunrise-154e7e8cd66f896dae4f4c3f4391bdbcf802e917.tar.gz
sunrise-154e7e8cd66f896dae4f4c3f4391bdbcf802e917.tar.bz2
sunrise-154e7e8cd66f896dae4f4c3f4391bdbcf802e917.zip
media-sound/basicdsp: New ebuild for bug 255364. Thanks to idl0r for help.
svn path=/sunrise/; revision=7665
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/basicdsp/ChangeLog8
-rw-r--r--media-sound/basicdsp/Manifest6
-rw-r--r--media-sound/basicdsp/basicdsp-1.01.ebuild37
-rw-r--r--media-sound/basicdsp/files/makefile.patch18
-rw-r--r--media-sound/basicdsp/metadata.xml5
5 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/basicdsp/ChangeLog b/media-sound/basicdsp/ChangeLog
new file mode 100644
index 000000000..497915951
--- /dev/null
+++ b/media-sound/basicdsp/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-sound/basicdsp
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 18 Jan 2009; Thomas Beierlein (TomJBE) <tb@forth-ev.de>
+ +basicdsp-1.01.ebuild, +files/makefile.patch, +metadata.xml:
+ New ebuild for bug 255364. Thanks to idl0r for help.
+
diff --git a/media-sound/basicdsp/Manifest b/media-sound/basicdsp/Manifest
new file mode 100644
index 000000000..1b2b01b65
--- /dev/null
+++ b/media-sound/basicdsp/Manifest
@@ -0,0 +1,6 @@
+AUX makefile.patch 653 RMD160 a7665d97e5587ba9a0d2b3d325e173fdef5fb727 SHA1 8ee6890deb9c42b5a601a49ef37c7d9df5b986b3 SHA256 6518e64c3c5c13663b77400b22b02fe37815bb2b5f0251c595446fe9e35ff67f
+DIST BasicDSP_SPRAT.pdf 83022 RMD160 b9fd7b43b1a355bdd079fc9d884b8ce4e9de841a SHA1 ad190a4d7902f4f11f2baebac8db8d32d59538d3 SHA256 fd780252447a647124a9e391eb4c349ddaca8c7f1dcddb278e1391b875ca3242
+DIST basicdsp-1.01.tgz 58080 RMD160 7d2abbb3fe09f4eb29ff822054f74a99166b49bf SHA1 0cd3a6def961537c286bfb45eba78e637406dad2 SHA256 0b01a9c1bf138de0deb54a55fd38871e0b2591a02eee0f3c33f8ee4a14e2364e
+EBUILD basicdsp-1.01.ebuild 886 RMD160 2016f5ae65daaeeb65444363a9cb6f12779951f3 SHA1 be21866837d6587e9e337db08d8eead1dc562693 SHA256 ba377c4b782488ea4f98770fc7bda84f9d6cc8b8da54a222a074cb049d824f25
+MISC ChangeLog 298 RMD160 9d0f6f0e147e7875c89da4347f3e184602df1583 SHA1 a8cc2a875e6b0a2ae7741b9d5811d40220f4ce62 SHA256 c8f7f0f80ab4423e701b87bc6f5270373a7205cccc2690022579f41e05e7f937
+MISC metadata.xml 171 RMD160 ed284df01c230fc7990a6b5888b39166d23f29ba SHA1 f3d64a69044b710e23fb874b3ee4cd338858c8b4 SHA256 a7b30fbacd0e4c312c07a3efac112a3794c81d134442d8104325734d03425adf
diff --git a/media-sound/basicdsp/basicdsp-1.01.ebuild b/media-sound/basicdsp/basicdsp-1.01.ebuild
new file mode 100644
index 000000000..ef1bc1a41
--- /dev/null
+++ b/media-sound/basicdsp/basicdsp-1.01.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A program for experimenting with simple audio DSP algorithms"
+HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/basicdsp/"
+SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/${P}.tgz
+ doc? ( http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/BasicDSP_SPRAT.pdf
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND=">=x11-libs/wxGTK-2.6.3"
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+
+ epatch "${FILESDIR}"/makefile.patch
+}
+
+src_install() {
+ dobin basicdsp || die "dobin failed"
+ doman basicdsp.1 || die "doman failed"
+ insinto /usr/share/pixmap
+ doins basicdsp_splash.xpm || die "doins failed"
+ dodoc README.txt || die "dodoc failed"
+ if use doc ; then
+ dodoc "${DISTDIR}"/BasicDSP_SPRAT.pdf || die "dodoc failed"
+ fi
+}
+
diff --git a/media-sound/basicdsp/files/makefile.patch b/media-sound/basicdsp/files/makefile.patch
new file mode 100644
index 000000000..cdc2b933f
--- /dev/null
+++ b/media-sound/basicdsp/files/makefile.patch
@@ -0,0 +1,18 @@
+--- Makefile.old 2009-01-18 12:08:12.744922218 +0100
++++ Makefile 2009-01-18 12:10:59.177907567 +0100
+@@ -1,5 +1,6 @@
+-CXXFLAGS = -O9 -g -Wall `wx-config --cxxflags` -g -Wall -pg
+-LDFLAGS = `wx-config --libs` -lm -g -pg
++CXXFLAGS ?= -O9 -g -Wall -pg
++CXXFLAGS += `wx-config --cxxflags`
++LIBS = `wx-config --libs` -lm
+
+ OBJS = aboutdialog.o book.o core.o displayslider.o graphframe.o gui.o linux.o vu_meter.o spectrumplot.o fft4g.o wav_streamer.o
+
+@@ -11,5 +12,5 @@ help.h: help_variables.html help_functio
+ ./mkhelp > help.h
+
+ basicdsp: help.h $(OBJS)
+- g++ $(LDFLAGS) $(OBJS) -o basicdsp
++ g++ $(CXXFLAGS) $(LDFLAGS) $(OBJS) -o basicdsp $(LIBS)
+ \ No newline at end of file
diff --git a/media-sound/basicdsp/metadata.xml b/media-sound/basicdsp/metadata.xml
new file mode 100644
index 000000000..6f1d493c5
--- /dev/null
+++ b/media-sound/basicdsp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+</pkgmetadata>