summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZeth Green (zeth) <theology@gmail.org>2007-04-06 20:49:57 +0000
committerZeth Green (zeth) <theology@gmail.org>2007-04-06 20:49:57 +0000
commitcf1d22da99084ebcb6f13a0281202246e3fb8e6d (patch)
treef4ea519391b4ef55bbff8023bca067a765dfacb9 /media-sound
parentRemove old and unmaintained Ubuntu engine for now. (diff)
downloadsunrise-cf1d22da99084ebcb6f13a0281202246e3fb8e6d.tar.gz
sunrise-cf1d22da99084ebcb6f13a0281202246e3fb8e6d.tar.bz2
sunrise-cf1d22da99084ebcb6f13a0281202246e3fb8e6d.zip
media-sound/jokosher: New Ebuild for bug 141362 thanks to Alex Rostovtsev and the bald yet beardy Jokosher people
svn path=/sunrise/; revision=3362
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/jokosher/ChangeLog9
-rw-r--r--media-sound/jokosher/Manifest5
-rw-r--r--media-sound/jokosher/files/jokosher6
-rw-r--r--media-sound/jokosher/jokosher-0.2.ebuild82
-rw-r--r--media-sound/jokosher/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/media-sound/jokosher/ChangeLog b/media-sound/jokosher/ChangeLog
new file mode 100644
index 000000000..66b15226e
--- /dev/null
+++ b/media-sound/jokosher/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-sound/jokosher
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 06 Apr 2007; Zeth Green (zeth) <theology@gmail.org> +jokosher-0.2.ebuild,
+ +files/jokosher, +metadata.xml:
+ New Ebuild for bug 141362 thanks to Alex Rostovtsev and the bald yet beardy
+ Jokosher people
+
diff --git a/media-sound/jokosher/Manifest b/media-sound/jokosher/Manifest
new file mode 100644
index 000000000..187955f22
--- /dev/null
+++ b/media-sound/jokosher/Manifest
@@ -0,0 +1,5 @@
+AUX jokosher 205 RMD160 ddd947da5b6f08a80968325b83f7a75e859026c8 SHA1 3cb92bf3ddb86972409c526f7b50a6f749e02c95 SHA256 874589a30b77e1e4ae9f366281bad58c60903eaca97bd7a78570242050c3c02b
+DIST jokosher-0.2.tar.gz 442351 RMD160 918bcd0c982d50f6bc627c866c7940ef0414582d SHA1 e51903d0d24d9e8f5c0920f5ff8ec0885f9613c2 SHA256 b4329558a246c5b5eb67fada56999fa09660a7bc348b5264bb8bd7330bddef5c
+EBUILD jokosher-0.2.ebuild 2178 RMD160 e5d3c7f7ae5cddd215b54f457733b90e992c0f6a SHA1 5838657166efa4e0f99426890cd0e1a599917d1b SHA256 3eb522b0c81edb4d02f546d56c06b7189cb9d20a49ea79e14ad8ec2641189942
+MISC ChangeLog 328 RMD160 28a8bb67711dc941b94058c4b1d7a25d7820a82f SHA1 24939081e227cc8e27025d89f0c21cf546ef6184 SHA256 8de956a7afdf4c3e4af15a504beadf5fdd0fb1321a993d6abbe698c942ca9af0
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/media-sound/jokosher/files/jokosher b/media-sound/jokosher/files/jokosher
new file mode 100644
index 000000000..567b4de28
--- /dev/null
+++ b/media-sound/jokosher/files/jokosher
@@ -0,0 +1,6 @@
+#!/bin/sh
+IPATH=/usr/share/jokosher
+export JOKOSHER_DATA_PATH="${IPATH}"
+export JOKOSHER_IMAGE_PATH="${IPATH}/images"
+export JOKOSHER_LOCALE_PATH="/usr/share/locale"
+exec /usr/share/jokosher/Jokosher "$@"
diff --git a/media-sound/jokosher/jokosher-0.2.ebuild b/media-sound/jokosher/jokosher-0.2.ebuild
new file mode 100644
index 000000000..cd194c619
--- /dev/null
+++ b/media-sound/jokosher/jokosher-0.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils python
+DESCRIPTION="A simple yet powerful multi-track studio"
+HOMEPAGE="http://www.jokosher.org/"
+SRC_URI="http://www.jokosher.org/scripts/download.php/src/www.jokosher.org/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.4
+ || ( dev-python/dbus-python ( >=sys-apps/dbus-0.60 <sys-apps/dbus-0.90 ) )
+ dev-python/gnome-python
+ >=dev-python/gst-python-0.10.6
+ dev-python/pycairo
+ >=dev-python/pygtk-2.8
+ dev-python/pyxml
+ dev-python/setuptools
+ gnome-base/librsvg
+ >=media-libs/gnonlin-0.10.6
+ >=media-libs/gst-plugins-good-0.10.5
+ >=media-libs/gstreamer-0.10.11
+ >=media-plugins/gst-plugins-alsa-0.10.9
+ >=media-plugins/gst-plugins-flac-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ >=media-plugins/gst-plugins-lame-0.10.3
+ >=media-plugins/gst-plugins-ogg-0.10
+ >=media-plugins/gst-plugins-vorbis-0.10
+ x11-themes/hicolor-icon-theme"
+
+DEPEND="${RDEPEND}"
+
+IPATH="/usr/share/${PN}"
+
+pkg_setup() {
+ # warn if dbus python bindings are not available (in case of <dbus-0.90)
+ if ! has_version dev-python/dbus-python && ! built_with_use sys-apps/dbus python
+ then
+ echo
+ eerror "Python dbus bindings not found."
+ eerror "Either emerge dev-python/dbus-python, or alternatively, rebuild"
+ eerror "<sys-apps-dbus-0.90 with python USE flag. To do so, try"
+ eerror "# echo \"sys-apps/dbus python\" >>/etc/portage/package.use"
+ eerror "or add python to USE in /etc/make.conf, and then run"
+ eerror "# emerge <sys-apps/dbus-0.90"
+ echo
+ die "Python dbus bindings must be installed."
+ fi
+}
+
+src_install() {
+ dobin "${FILESDIR}/${PN}"
+
+ cd "${WORKDIR}"
+ dodoc AUTHORS README
+
+ insinto "${IPATH}"
+ doins -r extensions images Instruments
+ doins Jokosher/*
+ fperms 755 "${IPATH}/Jokosher" "${IPATH}/JokosherApp.py"
+ doicon images/jokosher-icon.png
+ domenu jokosher.desktop
+
+ insinto /usr/share/locale
+ cd locale
+ doins -r *
+}
+
+pkg_postinst() {
+ python_mod_optimize "${IPATH}"
+ echo
+ einfo "Use /usr/bin/jokosher to run Jokosher ${PV}"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${IPATH}"
+}
diff --git a/media-sound/jokosher/metadata.xml b/media-sound/jokosher/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/media-sound/jokosher/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>